summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel R. van Rossum2015-06-18 16:27:37 -0500
committerDaniel R. van Rossum2015-06-18 16:27:37 -0500
commit861da5802c766680e8a838060f09d34d326bd9fd (patch)
treea1114bf13b3977af38a14836858580174a307994
downloadaur-861da5802c766680e8a838060f09d34d326bd9fd.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD27
-rwxr-xr-xlicense.txt8
-rwxr-xr-xvimdoc.install19
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..091f1040a673
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-visincr
+ pkgdesc = Produce increasing/decreasing columns of numbers, dates, or daynames
+ pkgver = 20
+ pkgrel = 2
+ url = http://www.vim.org/scripts/script.php?script_id=670
+ install = vimdoc.install
+ arch = i686
+ arch = x86_64
+ groups = vim-plugins
+ license = custom
+ depends = vim
+ source = vim-visincr.vba.gz::http://www.vim.org/scripts/download_script.php?src_id=16281
+ source = license.txt
+ md5sums = c306a1521171156abeb04390fee554fa
+ md5sums = efbd5986e691ce8c876fb86e8f5961ea
+
+pkgname = vim-visincr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..8d32e5f95ac9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Daan van Rossum <d.r.vanrossum @ gmx . de>
+pkgname=vim-visincr
+pkgver=20
+_scriptid=16281
+pkgrel=2
+pkgdesc="Produce increasing/decreasing columns of numbers, dates, or daynames"
+arch=(i686 x86_64)
+url="http://www.vim.org/scripts/script.php?script_id=670"
+license=('custom')
+depends=(vim)
+groups=('vim-plugins')
+install=vimdoc.install
+source=(${pkgname}.vba.gz::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid}
+ license.txt)
+md5sums=('c306a1521171156abeb04390fee554fa'
+ 'efbd5986e691ce8c876fb86e8f5961ea')
+
+package() {
+ install -d ${pkgdir}/usr/share/vim/vimfiles/{doc,plugin,autoload}
+ vim -c "UseVimball $srcdir" -c "q" ${pkgname}.vba
+ install -Dm755 ${srcdir}/doc/* ${pkgdir}/usr/share/vim/vimfiles/doc/ || return 1
+ rm ${pkgdir}/usr/share/vim/vimfiles/doc/tags
+ install -Dm755 ${srcdir}/plugin/* ${pkgdir}/usr/share/vim/vimfiles/plugin/ || return 1
+ install -Dm755 ${srcdir}/autoload/* ${pkgdir}/usr/share/vim/vimfiles/autoload/ || return 1
+ install -Dm755 ${srcdir}/license.txt ${pkgdir}/usr/share/licenses/${pkgname}/license.txt
+}
+
diff --git a/license.txt b/license.txt
new file mode 100755
index 000000000000..226f27b5356b
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,8 @@
+Copyright (C) 2002-2007 Yegappan Lakshmanan
+Permission is hereby granted to use and distribute this code,
+with or without modifications, provided that this copyright
+notice is copied with it. Like anything else that's free,
+taglist.vim is provided *as is* and comes with no warranty of any
+kind, either expressed or implied. In no event will the copyright
+holder be liable for any damamges resulting from the use of this
+software.
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100755
index 000000000000..5246e5c21134
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,19 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}
+
+op=$1
+shift
+
+$op $*