summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnkit R Gadiya2018-02-23 14:06:28 +0530
committerAnkit R Gadiya2018-02-23 14:06:28 +0530
commitb24889489f48696c43d3e4f4521ace82386aa9b6 (patch)
tree8e6dc8578794b3041b73df6e18a7b623e5cd601f
parenta14f5e1f36eb0d3e830714abed5964f61bd04aa2 (diff)
downloadaur-b24889489f48696c43d3e4f4521ace82386aa9b6.tar.gz
Updated to new version, small changes
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
-rwxr-xr-xvimdoc.install20
3 files changed, 13 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7002e7903f0..e13e5e2f4f70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = vim-voom
pkgdesc = VOoM - Vim two-pane outliner. Support mediawiki,rest,markdown,...
- pkgver = 5.1
+ pkgver = 5.3
pkgrel = 1
url = http://www.vim.org/scripts/script.php?script_id=2657
- install = vimdoc.install
arch = any
groups = vim-plugins
license = CCPL
- depends = vim-runtime
+ depends = vim
depends = python2
- conflicts = vim-voof
- replaces = vim-voof
- source = vim-voom.zip::http://www.vim.org/scripts/download_script.php?src_id=22082
- sha1sums = 676044c5ab32099961d8af4114616283a43dc4d7
+ source = vim-voom-5.3.zip::http://www.vim.org/scripts/download_script.php?src_id=25011
+ sha1sums = 52eab705d1f5640753213496befcab310633c844
pkgname = vim-voom
diff --git a/PKGBUILD b/PKGBUILD
index 0b89a91d1928..006b3497c3ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,22 @@
-# Maintainer: Daniel YC Lin <dlin <at> gmail.com>
+# Maintainer : Ankit R Gadiya <arch@argp.in>
+# Contributor: Daniel YC Lin <dlin <at> gmail.com>
# Contributor: Tianjiao Yin <ytj000@gmail.com>
# Contributor: Laszlo Papp <djszapi @ gmail at com>
pkgname=vim-voom
-pkgver=5.1
-_scriptid=22082
+pkgver=5.3
+_scriptid=25011
pkgrel=1
pkgdesc="VOoM - Vim two-pane outliner. Support mediawiki,rest,markdown,..."
arch=('any')
url="http://www.vim.org/scripts/script.php?script_id=2657"
license=('CCPL')
-depends=('vim-runtime' 'python2')
+depends=('vim' 'python2')
groups=('vim-plugins')
-conflicts=('vim-voof')
-replaces=('vim-voof')
-install=vimdoc.install
-source=(${pkgname}.zip::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid})
+source=("${pkgname}-${pkgver}.zip::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid}")
+sha1sums=('52eab705d1f5640753213496befcab310633c844')
package() {
- install -d ${pkgdir}/usr/share/vim/vimfiles
- #rm ${pkgname}.zip
- cp -a VOoM-$pkgver/* ${pkgdir}/usr/share/vim/vimfiles
+ install -dm755 "${pkgdir}"/usr/share/vim/vimfiles
+ cp -a VOoM-"${pkgver}"/* "${pkgdir}"/usr/share/vim/vimfiles
}
-sha1sums=('676044c5ab32099961d8af4114616283a43dc4d7')
diff --git a/vimdoc.install b/vimdoc.install
deleted file mode 100755
index 6b2d64f62b12..000000000000
--- a/vimdoc.install
+++ /dev/null
@@ -1,20 +0,0 @@
-post_install() {
- echo -n "Updating vim help tags..."
- /usr/bin/vim --noplugins -u NONE -U NONE \
- --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" \
- > /dev/null 2>&1
- echo "done."
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install
-}
-
-op=$1
-shift
-
-$op $*