summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiao Junxuan2023-08-06 15:07:54 +0800
committerLiao Junxuan2023-08-06 15:07:54 +0800
commitd1247043432980ce7db4baf85a32278fd459dca3 (patch)
tree3d0579902bc0dafdb984b2c1590ed3be90261cfc
downloadaur-d1247043432980ce7db4baf85a32278fd459dca3.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..446bf08d4e20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-wayland-clipboard-git
+ pkgdesc = Integrate Vim's '+' register with the Wayland system clipboard
+ pkgver = r22.9b6def0
+ pkgrel = 1
+ url = https://github.com/jasonccox/vim-wayland-clipboard
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = vim-plugin-runtime
+ provides = vim-wayland-clipboard
+ conflicts = vim-wayland-clipboard
+ source = git+https://github.com/jasonccox/vim-wayland-clipboard#branch=master
+ sha256sums = SKIP
+
+pkgname = vim-wayland-clipboard-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d12695d56b8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Liao Junxuan <mikeljx at 126 dot com>
+_pkgname=vim-wayland-clipboard
+pkgname=$_pkgname-git
+provides=($_pkgname)
+conflicts=($_pkgname)
+pkgver=r22.9b6def0
+pkgrel=1
+pkgdesc="Integrate Vim's '+' register with the Wayland system clipboard"
+arch=('any')
+url="https://github.com/jasonccox/vim-wayland-clipboard"
+license=('MIT')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+source=("git+$url#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ local _installpath="${pkgdir}/usr/share/vim/vimfiles"
+ install -d "${_installpath}"
+ find plugin -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/usr/share/vim/vimfiles/{}" \;
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}