summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2020-02-12 15:35:19 +0000
committerEric Engestrom2020-02-12 15:35:37 +0000
commit6845a9ed5068be0cd777f9847be1e9ac3baa8c30 (patch)
tree764479e150e967587f26c7ca85bc8d72357b9215
parent7fe082218edf9460ebe68880bf2159e7e3b0a729 (diff)
downloadaur-6845a9ed5068be0cd777f9847be1e9ac3baa8c30.tar.gz
fix PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD23
-rw-r--r--vim-helptags.install13
4 files changed, 12 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8980cd4980e..37ed6936c38a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = vim-webapi
pkgdesc = Vim Interface to Web API
- pkgver = 0.3.4.gdfc6063
+ pkgver = 0.3
pkgrel = 1
url = https://github.com/mattn/webapi-vim
- install = vim-helptags.install
arch = any
license = UNKNOWN
- makedepends = git
depends = vim
depends = curl
- source = git://github.com/mattn/webapi-vim.git
- md5sums = SKIP
+ source = https://github.com/mattn/webapi-vim/archive/0.3.tar.gz
+ sha256sums = 7e97e8ddb1497dae0226569cdf713418cfa0995913c8869339f50fe6bfb6f9f4
pkgname = vim-webapi
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..464ea1267f04
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/*.tar.gz
+/*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index 3bfdb54a8461..f016d70327c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,20 @@
-# Maintainer: Matt Monaco <cx monaco matt>
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+# contributor: Matt Monaco <cx monaco matt>
# contributor: Mikhail felixoid Shiryaev <mr.felixoid na gmail com>
pkgname=vim-webapi
-pkgver=0.3.4.gdfc6063
+pkgver=0.3
pkgrel=1
pkgdesc="Vim Interface to Web API"
arch=(any)
url=https://github.com/mattn/webapi-vim
license=(UNKNOWN)
depends=(vim curl)
-makedepends=(git)
-source=(git://github.com/mattn/webapi-vim.git)
-md5sums=(SKIP)
-install=vim-helptags.install
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=('7e97e8ddb1497dae0226569cdf713418cfa0995913c8869339f50fe6bfb6f9f4')
-pkgver()
-{
- cd "$srcdir"/webapi-vim
- local ver=$(git describe --tags )
- printf "%s" "${ver//-/.}"
-}
-
-package()
-{
- cd "$srcdir"/webapi-vim
+package() {
+ cd webapi-vim-$pkgver
for f in autoload/webapi/* doc/* example/*; do
install -D "$f" "$pkgdir"/usr/share/vim/vimfiles/"$f"
done
diff --git a/vim-helptags.install b/vim-helptags.install
deleted file mode 100644
index 5ae9bc91ff2a..000000000000
--- a/vim-helptags.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- printf "\e[1mUpdating vim help tags...\e[m"
- vim -e -s -c "helptags /usr/share/vim/vimfiles/doc/" -c "quit"
- printf " \e[1mdone\e[m\n"
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}