summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelixoid2015-11-23 20:22:32 +0300
committerfelixoid2015-11-23 20:22:32 +0300
commit577abd41910b2a5f25ab76bb4fa3e5a94646d067 (patch)
tree19bdc63736e44b2df29f2ca2949006ad2fffb0e5
downloadaur-577abd41910b2a5f25ab76bb4fa3e5a94646d067.tar.gz
move from old aur/vim-webapi
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
-rw-r--r--vim-helptags.install13
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8980cd4980e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-webapi
+ pkgdesc = Vim Interface to Web API
+ pkgver = 0.3.4.gdfc6063
+ pkgrel = 1
+ url = https://github.com/mattn/webapi-vim
+ install = vim-helptags.install
+ arch = any
+ license = UNKNOWN
+ makedepends = git
+ depends = vim
+ depends = curl
+ source = git://github.com/mattn/webapi-vim.git
+ md5sums = SKIP
+
+pkgname = vim-webapi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebe51d905adc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Matt Monaco <cx monaco matt>
+# contributor: Mikhail felixoid Shiryaev <mr.felixoid na gmail com>
+
+pkgname=vim-webapi-git
+pkgver=0.3.4.gdfc6063
+pkgrel=1
+pkgdesc="Vim Interface to Web API"
+arch=(any)
+url=https://github.com/mattn/webapi-vim
+license=(Public Domain)
+depends=(vim curl)
+makedepends=(git)
+source=(git://github.com/mattn/webapi-vim.git)
+md5sums=(SKIP)
+install=vim-helptags.install
+
+pkgver()
+{
+ cd "$srcdir"/webapi-vim
+ local ver=$(git describe --tags )
+ printf "%s" "${ver//-/.}"
+}
+
+package()
+{
+ cd "$srcdir"/webapi-vim
+ for f in autoload/webapi/* doc/* example/*; do
+ install -D "$f" "$pkgdir"/usr/share/vim/vimfiles/"$f"
+ done
+}
diff --git a/vim-helptags.install b/vim-helptags.install
new file mode 100644
index 000000000000..5ae9bc91ff2a
--- /dev/null
+++ b/vim-helptags.install
@@ -0,0 +1,13 @@
+post_install() {
+ printf "\e[1mUpdating vim help tags...\e[m"
+ vim -e -s -c "helptags /usr/share/vim/vimfiles/doc/" -c "quit"
+ printf " \e[1mdone\e[m\n"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}