summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-04-18 12:52:19 -0500
committerlmartinez-mirror2021-04-18 12:52:19 -0500
commit555aee2ea65db33b48bc48300dc4e15929e44cb5 (patch)
tree4d854ccb5aaac65b1e1f6ac925227b9fcd5358ee
downloadaur-555aee2ea65db33b48bc48300dc4e15929e44cb5.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD22
4 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1738e7b02521
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-wheel
+ pkgdesc = Quick navigation framework for Vim and Neovim
+ pkgver = 1.19
+ pkgrel = 1
+ url = https://github.com/chimay/wheel
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ depends = vim-plugin-runtime
+ source = vim-wheel-1.19.tar.gz::https://github.com/chimay/wheel/archive/refs/tags/v1.19.tar.gz
+ source = LICENSE
+ sha256sums = 041f016dc317c73563e13364d4b1487e88efddeae5479e35b4b262ea8f30bf33
+ sha256sums = b801c8d677ef9701149e05cf98f28b82a56832dd67c94d96d36d25d063b1b353
+
+pkgname = vim-wheel
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0713e0e78106
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+* \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..749aa1ecd9bd
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+The MIT License (MIT)
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98722efd9360
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+pkgname=vim-wheel
+pkgver=1.19
+pkgrel=1
+pkgdesc="Quick navigation framework for Vim and Neovim"
+arch=('any')
+url="https://github.com/chimay/wheel"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz"
+ "LICENSE")
+sha256sums=('041f016dc317c73563e13364d4b1487e88efddeae5479e35b4b262ea8f30bf33'
+ 'b801c8d677ef9701149e05cf98f28b82a56832dd67c94d96d36d25d063b1b353')
+
+package() {
+ cd "wheel-$pkgver"
+ find after autoload doc plugin \
+ -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm 644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}