summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-04-18 12:52:25 -0500
committerlmartinez-mirror2021-04-18 12:52:25 -0500
commitd6418b387a71e6c7ce54c7b0df24e83619871aa3 (patch)
tree49a0c52e833d15891c57d8f03f08a379399c3ee9
downloadaur-d6418b387a71e6c7ce54c7b0df24e83619871aa3.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD30
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..128820531433
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vim-wheel-git
+ pkgdesc = Quick navigation framework for Vim and Neovim
+ pkgver = 1.19.r7.gfc2512c
+ pkgrel = 1
+ url = https://github.com/chimay/wheel
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim-plugin-runtime
+ provides = vim-wheel
+ conflicts = vim-wheel
+ source = vim-wheel-git::git+https://github.com/chimay/wheel
+ source = LICENSE
+ sha256sums = SKIP
+ sha256sums = b801c8d677ef9701149e05cf98f28b82a56832dd67c94d96d36d25d063b1b353
+
+pkgname = vim-wheel-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0713e0e78106
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+* \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..749aa1ecd9bd
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+The MIT License (MIT)
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f33f51857caf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+pkgname=vim-wheel-git
+pkgver=1.19.r7.gfc2512c
+pkgrel=1
+pkgdesc="Quick navigation framework for Vim and Neovim"
+arch=('any')
+url="https://github.com/chimay/wheel"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url"
+ "LICENSE")
+sha256sums=('SKIP'
+ 'b801c8d677ef9701149e05cf98f28b82a56832dd67c94d96d36d25d063b1b353')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+package() {
+ cd "$pkgname"
+ find after autoload doc plugin \
+ -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm 644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}