summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-04-28 22:23:45 -0500
committerLuis Martinez2021-04-28 22:23:45 -0500
commitbbc107cc3a5e5bff1a8c00b098b8f9bfd6fcbfb1 (patch)
treee7f3a03a40ac782dff520d3bb3d465cb410dfcb7
downloadaur-bbc107cc3a5e5bff1a8c00b098b8f9bfd6fcbfb1.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4118e8090963
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-wiki-ft-git
+ pkgdesc = Simple Vim filetype plugin for Wiki files
+ pkgver = r23.03a6e36
+ pkgrel = 1
+ url = https://github.com/lervag/wiki-ft.vim
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim-plugin-runtime
+ depends = vim-wiki
+ provides = vim-wiki-ft
+ conflicts = vim-wiki-ft
+ source = vim-wiki-ft-git::git+https://github.com/lervag/wiki-ft.vim
+ sha256sums = SKIP
+
+pkgname = vim-wiki-ft-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd76f4c41ad6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=vim-wiki-ft-git
+pkgver=r23.03a6e36
+pkgrel=1
+pkgdesc="Simple Vim filetype plugin for Wiki files"
+arch=('any')
+url="https://github.com/lervag/wiki-ft.vim"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime' 'vim-wiki')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find autoload doc ftdetect ftplugin syntax \
+ -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dvm 644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+} \ No newline at end of file