summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Springer2019-05-25 17:30:18 +0200
committerFelix Springer2019-05-25 17:30:18 +0200
commitec556e9941b22c793e9025b64e71e6e1ae4083b8 (patch)
treeb8d5a54f762c7c10f544593725654f29524533ba
downloadaur-vim-wolfram.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c13a684e841
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = vim-wolfram
+ pkgdesc = Syntax Highlighting for Wolfram Language in Vim
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/arnoudbuzing/wolfram-vim
+ arch = x86_64
+ license = None
+ makedepends = git
+ source = git+https://github.com/arnoudbuzing/wolfram-vim.git
+ sha256sums = SKIP
+
+pkgname = vim-wolfram
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d91763d33f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Felix Springer <felixspringer149@gmail.com>
+
+pkgname=vim-wolfram
+pkgdesc="Syntax Highlighting for Wolfram Language in Vim"
+pkgver=0.1
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/arnoudbuzing/wolfram-vim"
+license=('None')
+depends=()
+optdepends=()
+makedepends=('git')
+source=('git+https://github.com/arnoudbuzing/wolfram-vim.git')
+_gitname="wolfram-vim"
+sha256sums=('SKIP')
+
+# To activate set in "~/.vim/filetype.vim":
+# autocmd BufRead,BufNewFile *.wl setfiletype wolfram
+# autocmd BufRead,BufNewFile *.wls setfiletype wolfram
+# autocmd BufRead,BufNewFile *.m setfiletype wolfram
+
+package() {
+ cd "${_gitname}"
+ install -Dm644 syntax/wl.vim ${pkgdir}/usr/share/vim/vimfiles/syntax/wolfram.vim
+}