summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-26 22:28:01 -0500
committerLuis Martinez2021-10-26 22:28:01 -0500
commit00ba2349dd0259fd8c92e17c593624f50c497d6d (patch)
treed2d227699cac3f723837243b048a53681507397c
downloadaur-00ba2349dd0259fd8c92e17c593624f50c497d6d.tar.gz
initial commit based on vim-wolfram
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..131fd256fbef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-wolfram-git
+ pkgdesc = Syntax Highlighting for Wolfram Language in Vim
+ pkgver = r17.cfc6118
+ pkgrel = 1
+ url = https://github.com/arnoudbuzing/wolfram-vim
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = vim-plugin-runtime
+ provides = vim-wolfram
+ conflicts = vim-wolfram
+ source = vim-wolfram-git::git+https://github.com/arnoudbuzing/wolfram-vim
+ sha256sums = SKIP
+
+pkgname = vim-wolfram-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33bb882ef6dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Felix Springer <felixspringer149@gmail.com>
+
+pkgname=vim-wolfram-git
+pkgdesc="Syntax Highlighting for Wolfram Language in Vim"
+pkgver=r17.cfc6118
+pkgrel=1
+arch=('any')
+url="https://github.com/arnoudbuzing/wolfram-vim"
+license=('unknown')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm 644 colors/wolframlanguage.vim -t "$pkgdir/usr/share/vim/vimfiles/colors/"
+ install -Dm 644 syntax/wl.vim -t "$pkgdir/usr/share/vim/vimfiles/syntax/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}