summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven-Hendrik Haase2020-07-14 01:33:19 +0200
committerSven-Hendrik Haase2020-07-14 01:33:19 +0200
commit4d1d375509bac7b99577efa133352820233c921f (patch)
treece70e778e0060a16317828d7e49b9792602526d6
downloadaur-4d1d375509bac7b99577efa133352820233c921f.tar.gz
Moved from [community]
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
-rw-r--r--vimdoc.install14
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..033afdd29971
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-workspace
+ pkgdesc = vim workspace manager plugin for managing groups of files
+ pkgver = 1.0b1
+ pkgrel = 10
+ url = http://www.vim.org/scripts/script.php?script_id=1410
+ arch = any
+ groups = vim-plugins
+ license = unknown
+ makedepends = unzip
+ depends = vim
+ source = https://www.vim.org/scripts/download_script.php?src_id=4812
+ md5sums = bd6828d19ce7c62aac0afe28b881a8ba
+
+pkgname = vim-workspace
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b06c99cb7fca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Aaron Griffin <aaron@archlinux.org>
+# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=vim-workspace
+pkgver=1.0b1
+_scriptid=4812
+pkgrel=10
+pkgdesc="vim workspace manager plugin for managing groups of files "
+arch=('any')
+url="http://www.vim.org/scripts/script.php?script_id=1410"
+license=('unknown')
+depends=('vim')
+makedepends=('unzip')
+groups=('vim-plugins')
+source=(https://www.vim.org/scripts/download_script.php?src_id=$_scriptid)
+md5sums=('bd6828d19ce7c62aac0afe28b881a8ba')
+
+build() {
+ cd ${srcdir}
+
+ mv download_script.php?src_id=$_scriptid workspace_1b1.zip
+ unzip -qqo workspace_1b1.zip
+}
+
+package() {
+ cd ${srcdir}
+
+ installpath="${pkgdir}/usr/share/vim/vimfiles"
+
+ install -D -m644 doc/workspace.txt \
+ $installpath/doc/workspace.txt
+ install -D -m644 plugin/workspace.vim \
+ $installpath/plugin/workspace.vim
+}
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..4bf6316dd78c
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}