summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiuseppe2017-07-21 15:11:16 +0200
committerGiuseppe2017-07-21 15:11:16 +0200
commit91c280ef7ea98f17ee76f62edf40dc879adcce84 (patch)
treec59c14e81145882ee235e3f4d9794b1b77d27e98
downloadaur-91c280ef7ea98f17ee76f62edf40dc879adcce84.tar.gz
Popolate repository.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a039928389b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = vim-wwdc17-theme-git
+ pkgdesc = Colorful light color scheme for Vim inspired by Apple's WWDC17 page
+ pkgver = v1.0.0.r20.gad0bf69
+ pkgrel = 1
+ url = https://github.com/lifepillar/vim-wwdc17-theme
+ arch = any
+ license = unknown
+ makedepends = git
+ source = git+https://github.com/lifepillar/vim-wwdc17-theme.git
+ md5sums = SKIP
+
+pkgname = vim-wwdc17-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa5ddae93ca6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Giuseppe Crino <giuscri@gmail.com>
+pkgname=vim-wwdc17-theme-git
+pkgdesc="Colorful light color scheme for Vim inspired by Apple's WWDC17 page"
+pkgrel=1
+pkgver=v1.0.0.r20.gad0bf69
+arch=('any')
+url="https://github.com/lifepillar/vim-wwdc17-theme"
+license=('unknown')
+md5sums=('SKIP')
+makedepends=('git')
+_pkgname=vim-wwdc17-theme
+source=("git+https://github.com/lifepillar/vim-wwdc17-theme.git")
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags| sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm644 colors/wwdc17.vim "$pkgdir/usr/share/vim/vimfiles/colors/wwdc17.vim"
+}
+
+# vim:set ts=2 sw=2 et: