summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilson E. Alvarez2018-12-19 18:08:14 -0500
committerWilson E. Alvarez2018-12-19 18:08:14 -0500
commit26b2a48b54924055eea0f8d658851b35c6aec5fd (patch)
tree2c5c3fac7b04b1e2815f2fb05f1f35f73a3bc7e4
parent7dfa1a8b330727f405180567ac9de70b773467e5 (diff)
downloadaur-26b2a48b54924055eea0f8d658851b35c6aec5fd.tar.gz
Updated dependencies
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD55
-rw-r--r--install.sh2
3 files changed, 44 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d4875f8b86d..8806c159cdc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vim-youcompleteme-git
pkgdesc = A code-completion engine for Vim
- pkgver = r2416.f67e5ff2
- pkgrel = 2
+ pkgver = r2449.0790dc99
+ pkgrel = 1
url = http://valloric.github.com/YouCompleteMe/
install = install.sh
arch = i686
@@ -30,14 +30,19 @@ pkgbase = vim-youcompleteme-git
source = git+https://github.com/ross/requests-futures.git
source = git+https://github.com/Valloric/ycmd.git
source = git+https://github.com/kennethreitz/requests.git
- source = git+https://github.com/bottlepy/bottle.git
+ source = git+https://github.com/kjd/idna.git
+ source = git+https://github.com/certifi/python-certifi.git
+ source = git+https://github.com/chardet/chardet.git
+ source = git+https://github.com/urllib3/urllib3.git
+ source = git+https://github.com/defnull/bottle.git
source = git+https://github.com/slezica/python-frozendict.git
source = git+https://github.com/PythonCharmers/python-future.git
source = git+https://github.com/davidhalter/jedi.git
source = git+https://github.com/davidhalter/parso.git
source = git+https://github.com/Pylons/waitress.git
- source = git+https://github.com/Manishearth/godef.git
- source = git+https://github.com/nsf/gocode.git
+ source = git+https://github.com/micbou/regex.git
+ source = git+https://github.com/mdempsky/gocode.git
+ source = git+https://github.com/rogpeppe/godef.git
source = git+https://github.com/nosami/OmniSharpServer.git
source = git+https://github.com/icsharpcode/NRefactory.git
source = git+https://github.com/jbevain/cecil.git
@@ -58,6 +63,11 @@ pkgbase = vim-youcompleteme-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = vim-youcompleteme-git
diff --git a/PKGBUILD b/PKGBUILD
index 45c51789c8db..b0d701e279db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,6 +18,7 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
# Contributor: edacval
# Contributor: MarcelPa
+# Contributor: Trent
@@ -42,12 +43,12 @@ _neovim="$NEOVIM_YOUCOMPLETEME"
# Default PKGBUILD Configuration #
#=========================================================================================================#
pkgname=vim-youcompleteme-git
-pkgver=r2416.f67e5ff2
+pkgver=r2449.0790dc99
pkgver() {
cd "YouCompleteMe" || exit
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pkgrel=2
+pkgrel=1
pkgdesc="A code-completion engine for Vim"
arch=('i686' 'x86_64')
url='http://valloric.github.com/YouCompleteMe/'
@@ -61,15 +62,19 @@ source=(
'git+https://github.com/ross/requests-futures.git' #ycm
'git+https://github.com/Valloric/ycmd.git' #ycm
'git+https://github.com/kennethreitz/requests.git' #ycmd
-'git+https://github.com/bottlepy/bottle.git' #ycmd
+'git+https://github.com/kjd/idna.git' #ycmd
+'git+https://github.com/certifi/python-certifi.git' #ycmd
+'git+https://github.com/chardet/chardet.git' #ycmd
+'git+https://github.com/urllib3/urllib3.git' #ycmd
+'git+https://github.com/defnull/bottle.git' #ycmd
'git+https://github.com/slezica/python-frozendict.git' #ycmd
'git+https://github.com/PythonCharmers/python-future.git' #ycmd
'git+https://github.com/davidhalter/jedi.git' #jedi
'git+https://github.com/davidhalter/parso.git' #jedi
'git+https://github.com/Pylons/waitress.git' #ycmd,jediHTTP
-'git+https://github.com/Manishearth/godef.git' #ycmd
+'git+https://github.com/micbou/regex.git' #ycmd
)
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
#=========================================================================================================#
#=========================================================================================================#
@@ -81,8 +86,9 @@ sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP
if [[ "$_gocode" == "y" ]]; then
# ycmd
- source+=('git+https://github.com/nsf/gocode.git')
- sha256sums+=('SKIP')
+ source+=('git+https://github.com/mdempsky/gocode.git'
+ 'git+https://github.com/rogpeppe/godef.git')
+ sha256sums+=('SKIP' 'SKIP')
makedepends+=('go')
fi
@@ -172,14 +178,12 @@ prepare() {
msg2 'Setting up Git submodules...'
- local YouCompleteMe=("requests-futures" "ycmd")
+ local YouCompleteMe=("requests-futures" "ycmd" "python-futures")
+ local YouCompleteMeRequestsDeps=("idna" "certifi" "chardet" "urllib3" "requests")
gitprepare "YouCompleteMe" "third_party/" "${YouCompleteMe[@]}"
+ gitprepare "YouCompleteMe" "third_party/requests_deps/" "${YouCompleteMeRequestsDeps[@]}"
- local ycmd=("bottle" "python-frozendict" "python-future" "waitress" "requests")
-
- if [[ "$_gocode" == "y" ]]; then
- ycmd+=("gocode" "godef")
- fi
+ local ycmd=("bottle" "regex" "python-frozendict" "jedi" "parso" "python-future" "waitress" "requests")
if [[ "$_omnisharp" == "y" ]]; then
ycmd+=("OmniSharpServer")
@@ -191,8 +195,10 @@ prepare() {
gitprepare "YouCompleteMe/third_party/ycmd" "third_party/" "${ycmd[@]}"
- local Jedi=("waitress" "jedi" "bottle" "parso")
- gitprepare "YouCompleteMe/third_party/ycmd/third_party/jedi" "vendor/" "${Jedi[@]}"
+ if [[ "$_gocode" == "y" ]]; then
+ gitprepare "YouCompleteMe/third_party/ycmd/third_party/go/src/github.com/mdempsky" "" "gocode"
+ gitprepare "YouCompleteMe/third_party/ycmd/third_party/go/src/github.com/rogpeppe" "" "godef"
+ fi
if [[ "$_omnisharp" == "y" ]]; then
local OmniSharpServer=("NRefactory" "cecil")
@@ -267,14 +273,17 @@ package() {
fi
mkdir -p "$pkgdir/$vimfiles_dir/third_party/ycmd/third_party"
+ mkdir -p "$pkgdir/$vimfiles_dir/third_party/requests_deps"
cp -r "$srcdir/YouCompleteMe/"{autoload,doc,plugin,python} \
"$pkgdir/$vimfiles_dir"
- cp -r "$srcdir/YouCompleteMe/third_party/"{pythonfutures,requests-futures} \
+ cp -r "$srcdir/YouCompleteMe/third_party/"{pythonfutures,requests-futures,python-future} \
"$pkgdir/$vimfiles_dir/third_party"
+ cp -r "$srcdir/YouCompleteMe/third_party/requests_deps/"{certifi,chardet,idna,requests,urllib3} \
+ "$pkgdir/$vimfiles_dir/third_party/requests_deps"
cp -r "$srcdir/YouCompleteMe/third_party/ycmd/"{ycmd,ycm_core.so,CORE_VERSION,clang_includes} \
"$pkgdir/$vimfiles_dir/third_party/ycmd"
- cp -r "$srcdir/YouCompleteMe/third_party/ycmd/third_party/"{bottle,parso,frozendict,jedi,python-future,requests,waitress} \
+ cp -r "$srcdir/YouCompleteMe/third_party/ycmd/third_party/"{bottle,cregex,frozendict,jedi,parso,python-future,requests,waitress} \
"$pkgdir/$vimfiles_dir/third_party/ycmd/third_party"
if [[ "$_omnisharp" == "y" ]]; then
@@ -320,22 +329,14 @@ package() {
rm -r "$pkgdir/$vimfiles_dir/third_party/ycmd/third_party/waitress/waitress/tests"
rm -r "$pkgdir/$vimfiles_dir/third_party/ycmd/third_party/bottle/test"
- # Remove any file we cannot compile using a specfic python version
- if [[ "$_use_python2" == "ON" ]]; then
- :
- else
- rm -r "$pkgdir/$vimfiles_dir/third_party/ycmd/third_party/bottle/plugins/werkzeug/bottle_werkzeug.py"
- rm -r "$pkgdir/$vimfiles_dir/third_party/ycmd/third_party/bottle/plugins/sqlite/bottle_sqlite.py"
- fi
-
# Remove unneeded docs
rm -r "$pkgdir/$vimfiles_dir/third_party/ycmd/third_party/python-future/docs"
# Finally compile all the python files to bytecode.
if [[ "$_use_python2" == "ON" ]]; then
- python2 -m compileall "$pkgdir"
+ python2 -m compileall "$pkgdir" || :
else
- python3 -m compileall "$pkgdir"
+ python3 -m compileall "$pkgdir" || :
fi
}
diff --git a/install.sh b/install.sh
index bfdd83f5b0f0..4848ada7a5c2 100644
--- a/install.sh
+++ b/install.sh
@@ -15,7 +15,7 @@ post_install() {
}
post_upgrade() {
- update_vim_help "$1"
+ update_vim_help
}
post_remove() {