summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2020-11-15 00:46:25 +0000
committerLeonidas Spyropoulos2020-11-15 00:46:25 +0000
commit29a87e2e25e4239a6f5f3d7ac015b7601d9b6c39 (patch)
tree4a57d14d7a6966cea70376dcb7c7d65c4dafd08f
parent5b11643f5f03647f87e1bb822b5d76a88a2e3595 (diff)
downloadaur-29a87e2e25e4239a6f5f3d7ac015b7601d9b6c39.tar.gz
upgpkg: vim-youcompleteme-git r2769.604a2a02-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e34e64c03311..a879fbafc12e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vim-youcompleteme-git
pkgdesc = A code-completion engine for Vim
- pkgver = r2764.21f1cc57
+ pkgver = r2769.604a2a02
pkgrel = 1
url = https://ycm-core.github.io/YouCompleteMe/
install = install.sh
@@ -29,7 +29,7 @@ pkgbase = vim-youcompleteme-git
source = git+https://github.com/davidhalter/parso.git
source = git+https://github.com/davidhalter/typeshed.git
source = git+https://github.com/kjd/idna.git
- source = git+https://github.com/micbou/regex.git
+ source = git+https://bitbucket.org/mrabarnett/mrab-regex.git
source = git+https://github.com/Pylons/waitress.git
source = git+https://github.com/PythonCharmers/python-future.git
source = git+https://github.com/requests/requests.git
diff --git a/PKGBUILD b/PKGBUILD
index c204ed103b79..75bb76b0ef0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Leonidas Spyropoulos <artafinde at gmail dot com>
+# Contributor: staletic
# Contributor: James Brink <brink.james@gmail.com>
# Contributor: Wilson E. Alvarez <wilson.e.alvarez1@gmail.com>
# Contributor: p <parimal@beyond8labs.com>
@@ -38,7 +39,7 @@ _neovim="$NEOVIM_YOUCOMPLETEME"
# Default PKGBUILD Configuration #
#=========================================================================================================#
pkgname=vim-youcompleteme-git
-pkgver=r2764.21f1cc57
+pkgver=r2769.604a2a02
pkgver() {
cd "YouCompleteMe" || exit
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -62,7 +63,7 @@ source=(
'git+https://github.com/davidhalter/parso.git'
'git+https://github.com/davidhalter/typeshed.git'
'git+https://github.com/kjd/idna.git'
- 'git+https://github.com/micbou/regex.git'
+ 'git+https://bitbucket.org/mrabarnett/mrab-regex.git'
'git+https://github.com/Pylons/waitress.git'
'git+https://github.com/PythonCharmers/python-future.git'
'git+https://github.com/requests/requests.git'
@@ -159,7 +160,7 @@ prepare() {
gitprepare "YouCompleteMe" "third_party/" "${YouCompleteMe[@]}"
gitprepare "YouCompleteMe" "third_party/requests_deps/" "${YouCompleteMeRequestsDeps[@]}"
- local ycmd=("bottle" "regex" "python-future" "waitress")
+ local ycmd=("bottle" "mrab-regex" "python-future" "waitress")
gitprepare "YouCompleteMe/third_party/ycmd" "third_party/" "${ycmd[@]}"
@@ -255,7 +256,7 @@ package() {
cp -r "$srcdir/YouCompleteMe/third_party/ycmd/"{ycmd,ycm_core.so,CORE_VERSION} \
"$pkgdir/$vimfiles_dir/third_party/ycmd"
- cp -r "$srcdir/YouCompleteMe/third_party/ycmd/third_party/"{bottle,clang,cregex,waitress} \
+ cp -r "$srcdir/YouCompleteMe/third_party/ycmd/third_party/"{bottle,clang,mrab-regex,waitress} \
"$pkgdir/$vimfiles_dir/third_party/ycmd/third_party"
cp -r "$srcdir/YouCompleteMe/third_party/ycmd/third_party/requests_deps/"{certifi,chardet,idna,requests,urllib3} \
"$pkgdir/$vimfiles_dir/third_party/ycmd/third_party/requests_deps"