summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Beran2016-04-07 10:24:37 -0700
committerErik Beran2016-04-07 10:24:37 -0700
commit618daac275cc0a120ad2ed992ffbb122101dd1e8 (patch)
treed80c2238cbfc360e7c3089c5b87432829170ce85
parentc1cf1eb5ab34510916068d73f136756a5d0179e4 (diff)
downloadaur-618daac275cc0a120ad2ed992ffbb122101dd1e8.tar.gz
Updating to clang, dependencies and correcting submodules
Updating clang/llvm to 3.8 Updating dependencies with libtinfo, needed for the Ubunutu build of clang/llvm. This must be manually installed prior to building as it is an AUR package and makepkg does not handle AUR dependncies. pacaur might.. Adding missing dependencies on boost and python Adding argparse repo path to JediHTTP submodule
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD13
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7f7bec1aa58..dcaa8724d726 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by makepkg 5.0.1
-# Mon Mar 7 19:57:01 UTC 2016
+# Thu Apr 7 17:20:49 UTC 2016
pkgbase = vim-youcompleteme-git
pkgdesc = A code-completion engine for Vim
- pkgver = 1747.381b213
+ pkgver = 1765.41e4886
pkgrel = 1
url = http://valloric.github.com/YouCompleteMe/
install = install
@@ -17,12 +17,16 @@ pkgbase = vim-youcompleteme-git
makedepends = make
makedepends = mono
makedepends = npm
+ depends = boost
+ depends = boost-libs
+ depends = libtinfo
depends = mono
depends = nodejs
+ depends = python
depends = python2
depends = rust
depends = vim
- noextract = clang+llvm-3.7.0-x86_64-linux-gnu-ubuntu-14.04.tar.xz
+ noextract = clang+llvm-3.8.0-x86_64-linux-gnu-ubuntu-14.04.tar.xz
source = git+https://github.com/Valloric/YouCompleteMe.git
source = git+https://github.com/ross/requests-futures.git
source = git+https://github.com/Valloric/ycmd.git
@@ -40,8 +44,8 @@ pkgbase = vim-youcompleteme-git
source = git+https://github.com/icsharpcode/NRefactory.git
source = git+https://github.com/jbevain/cecil.git
source = git+https://github.com/jwilm/racerd.git
- source = http://llvm.org/releases/3.7.0/clang+llvm-3.7.0-x86_64-linux-gnu-ubuntu-14.04.tar.xz
- source = http://llvm.org/releases/3.7.0/clang+llvm-3.7.0-x86_64-linux-gnu-ubuntu-14.04.tar.xz.sig
+ source = http://llvm.org/releases/3.8.0/clang+llvm-3.8.0-x86_64-linux-gnu-ubuntu-14.04.tar.xz
+ source = http://llvm.org/releases/3.8.0/clang+llvm-3.8.0-x86_64-linux-gnu-ubuntu-14.04.tar.xz.sig
validpgpkeys = B6C8F98282B944E3B0D5C2530FC3042E345AD05D
sha256sums = SKIP
sha256sums = SKIP
@@ -60,8 +64,8 @@ pkgbase = vim-youcompleteme-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 093a94ff8982ae78461f0d2604c98f6b454c15e2ef768d34c235c6676c336460
- sha256sums = 3251144f5f250b6cbb19041062f84c2c201d231b0f71d15631c65beb67582b0b
+ sha256sums = 3120c3055ea78bbbb6848510a2af70c68538b990cb0545bac8dad01df8ff69d7
+ sha256sums = 7cc55f1a1cc3e5478581e66c79ffa5ab4d7495076e6164b52d7b1a63816751a7
pkgname = vim-youcompleteme-git
diff --git a/PKGBUILD b/PKGBUILD
index 0bf9597e4784..680d69cb584f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,14 +13,14 @@
# Contributor: archdria
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
-_CLANG_LIB_FILENAME="libclang.so.3.7"
-_CLANG_VERSION="3.7.0"
+_CLANG_LIB_FILENAME="libclang.so.3.8"
+_CLANG_VERSION="3.8.0"
_CLANG_URL="http://llvm.org/releases/${_CLANG_VERSION}"
_CLANG_DIRNAME="clang+llvm-${_CLANG_VERSION}-x86_64-linux-gnu-ubuntu-14.04"
_CLANG_FILENAME="${_CLANG_DIRNAME}.tar.xz"
pkgname=vim-youcompleteme-git
-pkgver=1747.381b213
+pkgver=1765.41e4886
pkgver() {
cd "YouCompleteMe"
echo $(git rev-list --count master).$(git rev-parse --short master)
@@ -32,7 +32,7 @@ arch=('i686' 'x86_64')
url='http://valloric.github.com/YouCompleteMe/'
license=('GPL3')
groups=('vim-plugins')
-depends=('mono' 'nodejs' 'python2' 'rust' 'vim')
+depends=('boost' 'boost-libs' 'libtinfo' 'mono' 'nodejs' 'python' 'python2' 'rust' 'vim')
# use system's libclang on non-x86_64 architectures
[[ "${CARCH}" != 'x86_64' ]] && depends+=('clang')
makedepends=('cargo' 'cmake' 'git' 'go' 'make' 'mono' 'npm')
@@ -59,8 +59,8 @@ sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
if [[ "${CARCH}" == 'x86_64' ]]; then
# use bundled libclang on x86_64
source+=("${_CLANG_URL}/${_CLANG_FILENAME}"{,.sig})
- sha256sums+=('093a94ff8982ae78461f0d2604c98f6b454c15e2ef768d34c235c6676c336460'
- '3251144f5f250b6cbb19041062f84c2c201d231b0f71d15631c65beb67582b0b')
+ sha256sums+=('3120c3055ea78bbbb6848510a2af70c68538b990cb0545bac8dad01df8ff69d7'
+ '7cc55f1a1cc3e5478581e66c79ffa5ab4d7495076e6164b52d7b1a63816751a7')
validpgpkeys=('B6C8F98282B944E3B0D5C2530FC3042E345AD05D')
noextract=("${_CLANG_FILENAME}")
_COMPLETER="USE_CLANG_COMPLETER"
@@ -103,6 +103,7 @@ prepare() {
cd "$srcdir/YouCompleteMe/third_party/ycmd/third_party/JediHTTP"
git submodule init
+ git config submodule.vendor/argparse.url "$srcdir/argparse"
git config submodule.vendor/waitress.url "$srcdir/waitress"
git config submodule.vendor/jedi.url "$srcdir/jedi"
git config submodule.vendor/bottle.url "$srcdir/bottle"