summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilson E. Alvarez2018-07-29 08:37:00 -0400
committerWilson E. Alvarez2018-07-29 08:37:00 -0400
commit70b55e83867078a9cac739750b2b801fd4815c60 (patch)
treee163369c7262b4662387bfa0fa5ad53988abe98a
parenta87cf087d3737ac4a1c2c73d20ff0cc28a185d46 (diff)
downloadaur-70b55e83867078a9cac739750b2b801fd4815c60.tar.gz
Updated PKGBUILD to fix build error
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7afc1093044..21c5aa9a7a25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Apr 22 14:55:48 UTC 2018
pkgbase = vim-youcompleteme-git
pkgdesc = A code-completion engine for Vim
- pkgver = 2307.6975efdd
+ pkgver = 2373.15362d9c
pkgrel = 1
url = http://valloric.github.com/YouCompleteMe/
install = install
@@ -34,8 +32,8 @@ pkgbase = vim-youcompleteme-git
source = git+https://github.com/bottlepy/bottle.git
source = git+https://github.com/slezica/python-frozendict.git
source = git+https://github.com/PythonCharmers/python-future.git
- source = git+https://github.com/vheon/JediHTTP.git
source = git+https://github.com/davidhalter/jedi.git
+ source = git+https://github.com/davidhalter/parso.git
source = git+https://github.com/Pylons/waitress.git
source = git+https://github.com/nsf/gocode.git
source = git+https://github.com/Manishearth/godef.git
diff --git a/PKGBUILD b/PKGBUILD
index b952097086ab..8c6dfe04c3bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,7 +34,7 @@ _neovim="$NEOVIM_YOUCOMPLETEME"
###########################################################################################################
pkgname=vim-youcompleteme-git
-pkgver=2307.6975efdd
+pkgver=2373.15362d9c
pkgver() {
cd "YouCompleteMe" || exit
echo "$(git rev-list --count master).$(git rev-parse --short master)"
@@ -55,8 +55,8 @@ source=(
'git+https://github.com/bottlepy/bottle.git' #ycmd
'git+https://github.com/slezica/python-frozendict.git' #ycmd
'git+https://github.com/PythonCharmers/python-future.git' #ycmd
-'git+https://github.com/vheon/JediHTTP.git' #ycmd
-'git+https://github.com/davidhalter/jedi.git' #jediHTTP
+'git+https://github.com/davidhalter/jedi.git' #jedi
+'git+https://github.com/davidhalter/parso.git' #jedi
'git+https://github.com/Pylons/waitress.git' #ycmd,jediHTTP
'git+https://github.com/nsf/gocode.git' #ycmd
'git+https://github.com/Manishearth/godef.git' #ycmd
@@ -74,11 +74,11 @@ prepare() {
YouCompleteMe=("requests-futures" "ycmd")
gitprepare "YouCompleteMe" "third_party/" "${YouCompleteMe[@]}"
- ycmd=("bottle" "python-frozendict" "python-future" "JediHTTP" "waitress" "gocode" "godef" "OmniSharpServer" "requests" "racerd")
+ ycmd=("bottle" "python-frozendict" "python-future" "waitress" "gocode" "godef" "OmniSharpServer" "requests" "racerd")
gitprepare "YouCompleteMe/third_party/ycmd" "third_party/" "${ycmd[@]}"
- JediHTTP=("waitress" "jedi" "bottle")
- gitprepare "YouCompleteMe/third_party/ycmd/third_party/JediHTTP" "vendor/" "${JediHTTP[@]}"
+ Jedi=("waitress" "jedi" "bottle" "parso")
+ gitprepare "YouCompleteMe/third_party/ycmd/third_party/jedi" "vendor/" "${Jedi[@]}"
OmniSharpServer=("NRefactory" "cecil")
gitprepare "YouCompleteMe/third_party/ycmd/third_party/OmniSharpServer" "" "${OmniSharpServer[@]}"
@@ -168,7 +168,7 @@ package() {
"$pkgdir/$vimfiles_dir/third_party"
cp -r "$srcdir/YouCompleteMe/third_party/ycmd/"{ycmd,ycm_core.so,CORE_VERSION,cpp,clang_includes} \
"$pkgdir/$vimfiles_dir/third_party/ycmd"
- cp -r "$srcdir/YouCompleteMe/third_party/ycmd/third_party/"{bottle,frozendict,JediHTTP,python-future,requests,waitress} \
+ cp -r "$srcdir/YouCompleteMe/third_party/ycmd/third_party/"{bottle,parso,frozendict,jedi,python-future,requests,waitress} \
"$pkgdir/$vimfiles_dir/third_party/ycmd/third_party"
if [ "$_omnisharp" = "y" ]; then