summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Beran2016-02-09 09:58:24 -0800
committerErik Beran2016-02-09 10:02:00 -0800
commit760f6242f1b16da960ac096b6f1b5ed001ade808 (patch)
tree7ff97241f6faddb7537ecddcc65723ec7e01a82f
parentf20179d3da7d4702006d946564fcfea09fcbd666 (diff)
downloadaur-760f6242f1b16da960ac096b6f1b5ed001ade808.tar.gz
Updating tern building from upstream.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD8
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3082661db730..c55bcf03ddb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
-# Generated by makepkg 4.2.1
-# Tue Nov 24 05:18:57 UTC 2015
+# Generated by makepkg 5.0.0
+# Tue Feb 9 18:00:45 UTC 2016
pkgbase = vim-youcompleteme-git
pkgdesc = A code-completion engine for Vim
pkgver = 1591.96f0d94
@@ -10,30 +10,38 @@ pkgbase = vim-youcompleteme-git
arch = x86_64
groups = vim-plugins
license = GPL3
+ makedepends = cargo
makedepends = cmake
makedepends = git
makedepends = go
makedepends = make
makedepends = mono
- depends = vim
+ makedepends = npm
+ depends = mono
+ depends = nodejs
depends = python2
+ depends = rust
+ depends = vim
noextract = clang+llvm-3.7.0-x86_64-linux-gnu-ubuntu-14.04.tar.xz
source = git+https://github.com/Valloric/YouCompleteMe.git
source = git+https://github.com/kennethreitz/requests.git
source = git+https://github.com/ross/requests-futures.git
source = git+https://github.com/Valloric/ycmd.git
source = git+https://github.com/bewest/argparse.git
- source = git+https://github.com/defnull/bottle.git
+ source = git+https://github.com/bottlepy/bottle.git
source = git+https://github.com/slezica/python-frozendict.git
source = git+https://github.com/davidhalter/jedi.git
+ source = git+https://github.com/vheon/JediHTTP.git
source = git+https://github.com/Pylons/waitress.git
source = git+https://github.com/nsf/gocode.git
source = git+https://github.com/nosami/OmniSharpServer.git
source = git+https://github.com/icsharpcode/NRefactory.git
source = git+https://github.com/jbevain/cecil.git
- source = git+https://github.com/amoffat/sh.git
+ source = git+https://github.com/jwilm/racerd.git
source = http://llvm.org/releases/3.7.0/clang+llvm-3.7.0-x86_64-linux-gnu-ubuntu-14.04.tar.xz
source = http://llvm.org/releases/3.7.0/clang+llvm-3.7.0-x86_64-linux-gnu-ubuntu-14.04.tar.xz.sig
+ validpgpkeys = B6C8F98282B944E3B0D5C2530FC3042E345AD05D
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 78fee9d8a1a5..bff5ada51db3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,10 +50,9 @@ source=('git+https://github.com/Valloric/YouCompleteMe.git'
'git+https://github.com/nosami/OmniSharpServer.git'
'git+https://github.com/icsharpcode/NRefactory.git'
'git+https://github.com/jbevain/cecil.git'
- 'git+https://github.com/ternjs/tern.git'
'git+https://github.com/jwilm/racerd.git')
sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
- 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
if [[ "${CARCH}" == 'x86_64' ]]; then
# use bundled libclang on x86_64
source+=("${_CLANG_URL}/${_CLANG_FILENAME}"{,.sig})
@@ -95,7 +94,6 @@ prepare() {
git config submodule.third_party/OmniSharpServer.url "$srcdir/OmniSharpServer"
git config submodule.third_party/requests.url "$srcdir/requests"
git config submodule.third_party/racerd.url "$srcdir/racerd"
- git config submodule.third_party/tern.url "$srcdir/tern"
git submodule update
cd "$srcdir/YouCompleteMe/third_party/ycmd/third_party/JediHTTP"
@@ -144,7 +142,7 @@ build() {
cargo build --release
msg2 'Building Tern completer...' # SetUpTern()
- cd "$srcdir/YouCompleteMe/third_party/ycmd/third_party/tern"
+ cd "$srcdir/YouCompleteMe/third_party/ycmd/third_party/tern_runtime"
pwd
npm install --production --python=python2
# }}}
@@ -169,7 +167,7 @@ package() {
"$pkgdir/usr/share/vim/vimfiles/third_party/ycmd/clang_includes"
fi
- cp -r "$srcdir/YouCompleteMe/third_party/ycmd/third_party/"{argparse,bottle,frozendict,JediHTTP,requests,tern,waitress} \
+ cp -r "$srcdir/YouCompleteMe/third_party/ycmd/third_party/"{argparse,bottle,frozendict,JediHTTP,requests,tern_runtime,waitress} \
"$pkgdir/usr/share/vim/vimfiles/third_party/ycmd/third_party"
cp "$srcdir/YouCompleteMe/third_party/ycmd/third_party/gocode/gocode" \