summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2020-12-09 12:25:26 +0000
committerLeonidas Spyropoulos2020-12-09 12:25:26 +0000
commit9cb81bc888dae39e8291275bd23bc52bbca9a0a3 (patch)
tree9fb66de5f7e0a4d78d82f99373ca014636e176e2
parent5ec265af8b041fb04d3f0180744098674d7e3951 (diff)
downloadaur-9cb81bc888dae39e8291275bd23bc52bbca9a0a3.tar.gz
upgpkg: vim-youcompleteme-git r2774.4496153a-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd508d7a6e7d..43ad420db0fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -28,8 +28,6 @@ pkgbase = vim-youcompleteme-git
optdepends = java-environment>=11: Java semantic completion
optdepends = jdtls: Java semantic completion
source = git+https://github.com/ycm-core/YouCompleteMe.git
- source = git+https://github.com/ycm-core/ycmd.git
- sha256sums = SKIP
sha256sums = SKIP
pkgname = vim-youcompleteme-git
diff --git a/PKGBUILD b/PKGBUILD
index dced3db6dcbd..7fe27b56af1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -56,10 +56,8 @@ optdepends=(
'omnisharp-roslyn: C# semantic completion'
'java-environment>=11: Java semantic completion'
'jdtls: Java semantic completion')
-source=(git+https://github.com/ycm-core/YouCompleteMe.git
- git+https://github.com/ycm-core/ycmd.git)
-sha256sums=('SKIP'
- 'SKIP')
+source=(git+https://github.com/ycm-core/YouCompleteMe.git)
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}"/YouCompleteMe || exit
@@ -69,11 +67,9 @@ pkgver() {
prepare() {
cd "${srcdir}"/YouCompleteMe || exit
git submodule init third_party/ycmd
- git config submodule.third_party/ycmd.url "${srcdir}/ycmd"
- git submodule update
+ git submodule update third_party/ycmd
- # NOTE: Arch package for pybind11 2.6.0 doesn't ship headers
- # Force system headers/libs
+ rm -rf "${srcdir}"/YouCompleteMe/third_party/ycmd/cpp/pybind11 || exit
rm -rf "${srcdir}"/YouCompleteMe/third_party/ycmd/cpp/llvm || exit
if [[ "$_gocode" == "y" ]]; then
@@ -101,6 +97,8 @@ prepare() {
-e 's|\(roslyn_binary_path":\).*$|\1 "/opt/omnisharp-roslyn/OmniSharp.exe",|' \
-e 's|\(mono_binary_path":\).*$|\1 "/usr/bin/mono",|' \
-i "${srcdir}"/YouCompleteMe/third_party/ycmd/ycmd/default_settings.json
+ # The 'ycm_clangd_binary_path' option is overriden from the vim plugin
+ # so just make sure this is also done there.
sed -e "s|\(ycm_clangd_binary_path',\).*\$|\1 '/usr/bin/clangd' )|" \
-i "${srcdir}"/YouCompleteMe/plugin/youcompleteme.vim
}