summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Beran2016-03-07 11:59:25 -0800
committerErik Beran2016-03-07 11:59:25 -0800
commitc1cf1eb5ab34510916068d73f136756a5d0179e4 (patch)
treeed939ad6e0ab7d2255079616f061fc1c31399c12
parent16dbdc34b3c575242a03bcde5c9c5b7eac70e9ac (diff)
downloadaur-c1cf1eb5ab34510916068d73f136756a5d0179e4.tar.gz
Using bundled python-future package, clearer PKGBUILD src dependencies
Correctly pulling python-future source for bundle rather than package dependency. There is potential for using the system one..needs some testing, but we will guarantee loss of upstream support (which I guess we already have because of system level packaging). Reordered git module URLs and added some tags as to where they exist or what project depends on them.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD43
2 files changed, 30 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6476eb68bc4a..f7f7bec1aa58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
-# Generated by makepkg 5.0.0
-# Tue Mar 1 06:23:59 UTC 2016
+# Generated by makepkg 5.0.1
+# Mon Mar 7 19:57:01 UTC 2016
pkgbase = vim-youcompleteme-git
pkgdesc = A code-completion engine for Vim
- pkgver = 1709.94ec3ed
+ pkgver = 1747.381b213
pkgrel = 1
url = http://valloric.github.com/YouCompleteMe/
install = install
@@ -20,19 +20,19 @@ pkgbase = vim-youcompleteme-git
depends = mono
depends = nodejs
depends = python2
- depends = python2-future
depends = rust
depends = vim
noextract = clang+llvm-3.7.0-x86_64-linux-gnu-ubuntu-14.04.tar.xz
source = git+https://github.com/Valloric/YouCompleteMe.git
- source = git+https://github.com/kennethreitz/requests.git
source = git+https://github.com/ross/requests-futures.git
source = git+https://github.com/Valloric/ycmd.git
+ source = git+https://github.com/kennethreitz/requests.git
source = git+https://github.com/bewest/argparse.git
source = git+https://github.com/bottlepy/bottle.git
source = git+https://github.com/slezica/python-frozendict.git
- source = git+https://github.com/davidhalter/jedi.git
+ source = git+https://github.com/PythonCharmers/python-future.git
source = git+https://github.com/vheon/JediHTTP.git
+ source = git+https://github.com/davidhalter/jedi.git
source = git+https://github.com/Pylons/waitress.git
source = git+https://github.com/nsf/gocode.git
source = git+https://github.com/Manishearth/godef.git
@@ -59,6 +59,7 @@ pkgbase = vim-youcompleteme-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 093a94ff8982ae78461f0d2604c98f6b454c15e2ef768d34c235c6676c336460
sha256sums = 3251144f5f250b6cbb19041062f84c2c201d231b0f71d15631c65beb67582b0b
diff --git a/PKGBUILD b/PKGBUILD
index 5eeb4481af4f..0bf9597e4784 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ _CLANG_DIRNAME="clang+llvm-${_CLANG_VERSION}-x86_64-linux-gnu-ubuntu-14.04"
_CLANG_FILENAME="${_CLANG_DIRNAME}.tar.xz"
pkgname=vim-youcompleteme-git
-pkgver=1709.94ec3ed
+pkgver=1747.381b213
pkgver() {
cd "YouCompleteMe"
echo $(git rev-list --count master).$(git rev-parse --short master)
@@ -32,27 +32,29 @@ arch=('i686' 'x86_64')
url='http://valloric.github.com/YouCompleteMe/'
license=('GPL3')
groups=('vim-plugins')
-depends=('mono' 'nodejs' 'python2' 'python2-future' 'rust' 'vim')
+depends=('mono' 'nodejs' 'python2' 'rust' 'vim')
# use system's libclang on non-x86_64 architectures
[[ "${CARCH}" != 'x86_64' ]] && depends+=('clang')
makedepends=('cargo' 'cmake' 'git' 'go' 'make' 'mono' 'npm')
-source=('git+https://github.com/Valloric/YouCompleteMe.git'
- 'git+https://github.com/kennethreitz/requests.git'
- 'git+https://github.com/ross/requests-futures.git'
- 'git+https://github.com/Valloric/ycmd.git'
- 'git+https://github.com/bewest/argparse.git'
- 'git+https://github.com/bottlepy/bottle.git'
- 'git+https://github.com/slezica/python-frozendict.git'
- 'git+https://github.com/davidhalter/jedi.git'
- 'git+https://github.com/vheon/JediHTTP.git'
- 'git+https://github.com/Pylons/waitress.git'
- 'git+https://github.com/nsf/gocode.git'
- 'git+https://github.com/Manishearth/godef.git'
- 'git+https://github.com/nosami/OmniSharpServer.git'
- 'git+https://github.com/icsharpcode/NRefactory.git'
- 'git+https://github.com/jbevain/cecil.git'
- 'git+https://github.com/jwilm/racerd.git')
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+source=('git+https://github.com/Valloric/YouCompleteMe.git' #ycm
+ 'git+https://github.com/ross/requests-futures.git' #ycm
+ 'git+https://github.com/Valloric/ycmd.git' #ycm
+ 'git+https://github.com/kennethreitz/requests.git' #ycmd
+ 'git+https://github.com/bewest/argparse.git' #ycmd
+ 'git+https://github.com/bottlepy/bottle.git' #ycmd
+ 'git+https://github.com/slezica/python-frozendict.git' #ycmd
+ 'git+https://github.com/PythonCharmers/python-future.git' #ycmd
+ 'git+https://github.com/vheon/JediHTTP.git' #ycmd
+ 'git+https://github.com/davidhalter/jedi.git' #jediHTTP
+ 'git+https://github.com/Pylons/waitress.git' #ycmd,jediHTTP
+ 'git+https://github.com/nsf/gocode.git' #ycmd
+ 'git+https://github.com/Manishearth/godef.git' #ycmd
+ 'git+https://github.com/nosami/OmniSharpServer.git' #ycmd
+ 'git+https://github.com/icsharpcode/NRefactory.git' #OmniSharpServer
+ 'git+https://github.com/jbevain/cecil.git' #OmniSharpServer
+ 'git+https://github.com/jwilm/racerd.git' #ycmd
+ )
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
if [[ "${CARCH}" == 'x86_64' ]]; then
# use bundled libclang on x86_64
@@ -89,6 +91,7 @@ prepare() {
git config submodule.third_party/argparse.url "$srcdir/argparse"
git config submodule.third_party/bottle.url "$srcdir/bottle"
git config submodule.third_party/frozendict.url "$srcdir/python-frozendict"
+ git config submodule.third_party/python-future.url "$srcdir/python-future"
git config submodule.third_party/JediHTTP.url "$srcdir/JediHTTP"
git config submodule.third_party/waitress.url "$srcdir/waitress"
git config submodule.third_party/gocode.url "$srcdir/gocode"
@@ -173,7 +176,7 @@ package() {
"$pkgdir/usr/share/vim/vimfiles/third_party/ycmd/clang_includes"
fi
- cp -r "$srcdir/YouCompleteMe/third_party/ycmd/third_party/"{argparse,bottle,frozendict,JediHTTP,requests,tern_runtime,waitress} \
+ cp -r "$srcdir/YouCompleteMe/third_party/ycmd/third_party/"{argparse,bottle,frozendict,JediHTTP,python-future,requests,tern_runtime,waitress} \
"$pkgdir/usr/share/vim/vimfiles/third_party/ycmd/third_party"
cp "$srcdir/YouCompleteMe/third_party/ycmd/third_party/gocode/gocode" \