summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Roest2018-02-13 21:19:20 +0100
committerVictor Roest2018-02-13 21:19:20 +0100
commitd1166ddbf1f607186299db0962e6e8e1238e6b14 (patch)
treebda94235f2e3ede1a82d44d366679aee003c1da5
parent287e486c299ea35c95fe8dd1e854dba9cdbaeb35 (diff)
downloadaur-d1166ddbf1f607186299db0962e6e8e1238e6b14.tar.gz
Removed any mentions of argparse
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e9f5efb7b3a..f312709f0f1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vim-youcompleteme-git
pkgdesc = A code-completion engine for Vim
- pkgver = 2068.ba779aff
+ pkgver = 2258.02f11703
pkgrel = 1
url = http://valloric.github.com/YouCompleteMe/
install = install
@@ -29,7 +29,6 @@ pkgbase = vim-youcompleteme-git
source = git+https://github.com/ross/requests-futures.git
source = git+https://github.com/Valloric/ycmd.git
source = git+https://github.com/kennethreitz/requests.git
- source = git+https://github.com/bewest/argparse.git
source = git+https://github.com/bottlepy/bottle.git
source = git+https://github.com/slezica/python-frozendict.git
source = git+https://github.com/PythonCharmers/python-future.git
@@ -58,7 +57,6 @@ pkgbase = vim-youcompleteme-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
pkgname = vim-youcompleteme-git
diff --git a/PKGBUILD b/PKGBUILD
index edebcd80e423..cd47f459509f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,7 +31,7 @@ _completer="ON"
###########################################################################################################
pkgname=vim-youcompleteme-git
-pkgver=2068.ba779aff
+pkgver=2258.02f11703
pkgver() {
cd "YouCompleteMe" || exit
echo "$(git rev-list --count master).$(git rev-parse --short master)"
@@ -49,7 +49,6 @@ source=('git+https://github.com/Valloric/YouCompleteMe.git' #ycm
'git+https://github.com/ross/requests-futures.git' #ycm
'git+https://github.com/Valloric/ycmd.git' #ycm
'git+https://github.com/kennethreitz/requests.git' #ycmd
- 'git+https://github.com/bewest/argparse.git' #ycmd
'git+https://github.com/bottlepy/bottle.git' #ycmd
'git+https://github.com/slezica/python-frozendict.git' #ycmd
'git+https://github.com/PythonCharmers/python-future.git' #ycmd
@@ -63,7 +62,7 @@ source=('git+https://github.com/Valloric/YouCompleteMe.git' #ycm
'git+https://github.com/jbevain/cecil.git' #OmniSharpServer
'git+https://github.com/jwilm/racerd.git' #ycmd
)
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
install=install
@@ -73,10 +72,10 @@ prepare() {
YouCompleteMe=("requests-futures" "ycmd")
gitprepare "YouCompleteMe" "third_party/" "${YouCompleteMe[@]}"
- ycmd=("argparse" "bottle" "python-frozendict" "python-future" "JediHTTP" "waitress" "gocode" "godef" "OmniSharpServer" "requests" "racerd")
+ ycmd=("bottle" "python-frozendict" "python-future" "JediHTTP" "waitress" "gocode" "godef" "OmniSharpServer" "requests" "racerd")
gitprepare "YouCompleteMe/third_party/ycmd" "third_party/" "${ycmd[@]}"
- JediHTTP=("argparse" "waitress" "jedi" "bottle")
+ JediHTTP=("waitress" "jedi" "bottle")
gitprepare "YouCompleteMe/third_party/ycmd/third_party/JediHTTP" "vendor/" "${JediHTTP[@]}"
OmniSharpServer=("NRefactory" "cecil")
@@ -103,6 +102,7 @@ gitprepare() {
}
build() {
+ #rm -rf $srcdir/YouCompleteMe/python/ycm/tests
msg2 'Building ycmd...' # BuildYcmdLibs()
mkdir -p "$srcdir/ycmd_build"
cd "$srcdir/ycmd_build" || exit
@@ -158,7 +158,7 @@ package() {
"$pkgdir/usr/share/vim/vimfiles/third_party"
cp -r "$srcdir/YouCompleteMe/third_party/ycmd/"{ycmd,ycm_core.so,CORE_VERSION,cpp,clang_includes} \
"$pkgdir/usr/share/vim/vimfiles/third_party/ycmd"
- cp -r "$srcdir/YouCompleteMe/third_party/ycmd/third_party/"{argparse,bottle,frozendict,JediHTTP,python-future,requests,waitress} \
+ cp -r "$srcdir/YouCompleteMe/third_party/ycmd/third_party/"{bottle,frozendict,JediHTTP,python-future,requests,waitress} \
"$pkgdir/usr/share/vim/vimfiles/third_party/ycmd/third_party"
if [ "$_omnisharp" = "y" ]; then