summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2019-12-04 21:41:16 +0000
committerLeonidas Spyropoulos2019-12-04 21:41:16 +0000
commitf5b11f65c7d08aedf8f5ab35e29eebb51d8fc940 (patch)
tree3b2bbeb3fd8bbb198f360baf232f6cc177c4c2af
parent4d29e7488d48dce54b4629763309efe32ddebeae (diff)
downloadaur-f5b11f65c7d08aedf8f5ab35e29eebb51d8fc940.tar.gz
upgpkg: vim-youcompleteme-git r2585.1386c6b3-1
upstream release
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3277efccff1..4afc9d6b4a3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vim-youcompleteme-git
pkgdesc = A code-completion engine for Vim
- pkgver = r2565.036ad6e9
+ pkgver = r2585.1386c6b3
pkgrel = 1
url = https://ycm-core.github.io/YouCompleteMe/
install = install.sh
@@ -27,6 +27,7 @@ pkgbase = vim-youcompleteme-git
source = git+https://github.com/chardet/chardet.git
source = git+https://github.com/davidhalter/jedi.git
source = git+https://github.com/davidhalter/parso.git
+ source = git+https://github.com/davidhalter/typeshed.git
source = git+https://github.com/kjd/idna.git
source = git+https://github.com/micbou/regex.git
source = git+https://github.com/Pylons/waitress.git
@@ -54,6 +55,7 @@ pkgbase = vim-youcompleteme-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 266b90d50bff43b6d0a011462239dcf261f5a97a5b1f110b4a7e063670963dae
sha256sums = cde1d1265be82e246edb6021e0a4b4e01af1a140b8d92b05bde6929e922ae215
diff --git a/PKGBUILD b/PKGBUILD
index 604021cbed50..11547f30be71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,7 +39,7 @@ _neovim="$NEOVIM_YOUCOMPLETEME"
# Default PKGBUILD Configuration #
#=========================================================================================================#
pkgname=vim-youcompleteme-git
-pkgver=r2565.036ad6e9
+pkgver=r2585.1386c6b3
pkgver() {
cd "YouCompleteMe" || exit
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -61,6 +61,7 @@ source=(
'git+https://github.com/chardet/chardet.git'
'git+https://github.com/davidhalter/jedi.git'
'git+https://github.com/davidhalter/parso.git'
+ 'git+https://github.com/davidhalter/typeshed.git'
'git+https://github.com/kjd/idna.git'
'git+https://github.com/micbou/regex.git'
'git+https://github.com/Pylons/waitress.git'
@@ -74,7 +75,7 @@ source=(
'omnisharp.patch'
'rls.patch')
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'266b90d50bff43b6d0a011462239dcf261f5a97a5b1f110b4a7e063670963dae'
'cde1d1265be82e246edb6021e0a4b4e01af1a140b8d92b05bde6929e922ae215')
@@ -156,6 +157,9 @@ prepare() {
local ycmdRequestsDeps=("python-certifi" "chardet" "idna" "requests" "urllib3")
gitprepare "YouCompleteMe/third_party/ycmd" "third_party/requests_deps" "${ycmdRequestsDeps[@]}"
+
+ local jedi=("typeshed")
+ gitprepare "YouCompleteMe/third_party/ycmd/third_party/jedi_deps/jedi" "jedi/third_party/" "${jedi[@]}"
if [[ "$_gocode" == "y" ]]; then
ycmd+=("go-completer")