summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Timm2019-03-29 13:15:31 +0100
committerRobert Timm2019-03-29 13:15:31 +0100
commit56ae4aaa7be77d7d48e9512f2050be3c506b8e16 (patch)
tree978216e8fb9697190446103f636aeeb7984bf884
parent5cc470952944ec9ad664ca3b0fe275760954b5f1 (diff)
downloadaur-56ae4aaa7be77d7d48e9512f2050be3c506b8e16.tar.gz
update to vimb 3.4.0
-rw-r--r--.SRCINFO15
-rw-r--r--0001-Makefile-fix-compilation-if-source-is-not-in-a-git-r.patch42
-rw-r--r--PKGBUILD13
3 files changed, 58 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e4f114a4b18..753ec0f46687 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = vimb
pkgdesc = The vim like browser
- pkgver = 3.3.0
- pkgrel = 2
+ pkgver = 3.4.0
+ pkgrel = 1
url = http://fanglingsu.github.io/vimb
arch = i686
arch = x86_64
license = GPLv3
- depends = webkit2gtk>=2.8,
+ depends = webkit2gtk>=2.20,
depends = pkgconf
provides = vimb
conflicts = vimb2
conflicts = vimb-gtk2
conflicts = vimb-git
- source = vimb-3.3.0.tar.gz::https://github.com/fanglingsu/vimb/archive/3.3.0.tar.gz
- md5sums = b6e69c0efc5546bdc91453741ff25a90
- sha256sums = 5c6fe39b1b2ca18a342bb6683f7fd5b139ead53903f57dd9eecd5a1074576d6c
+ source = vimb-3.4.0.tar.gz::https://github.com/fanglingsu/vimb/archive/3.4.0.tar.gz
+ source = 0001-Makefile-fix-compilation-if-source-is-not-in-a-git-r.patch
+ md5sums = befacbb3089627a516cf8f12ac389b98
+ md5sums = 0899d1692c08b261bc576ed354acf797
+ sha256sums = 36838f509a2ec55515eaf51bbe8c4885f3ef20847f0f42d36103dcfddaf5b39a
+ sha256sums = 15b6fedc1612088d74e8699dac440ffa0ae80ed81a93c5d871437b521236563d
pkgname = vimb
diff --git a/0001-Makefile-fix-compilation-if-source-is-not-in-a-git-r.patch b/0001-Makefile-fix-compilation-if-source-is-not-in-a-git-r.patch
new file mode 100644
index 000000000000..faa16d58a4bd
--- /dev/null
+++ b/0001-Makefile-fix-compilation-if-source-is-not-in-a-git-r.patch
@@ -0,0 +1,42 @@
+From 0eda3ec2ac78577a08ace4c18cd9e912a56609e6 Mon Sep 17 00:00:00 2001
+From: Patrick Steinhardt <ps@pks.im>
+Date: Wed, 27 Mar 2019 07:47:30 +0100
+Subject: [PATCH] Makefile: fix compilation if source is not in a git repo
+
+To make the version available, the Makefile creates a "version.h"
+header. This file will either contain the output of `git describe
+--tags` or a fallback value that is declared inside the Makefile
+itself.
+
+This logic is broken as there is a hard dependcy on the
+".git/index" file. The intent here is to regenerate the header
+file whenever there is any change to the git repo itself. But in
+case where vimb is for example being compiled from a tarball,
+there will be no git index at all, leading to an error "No rule
+to make target '.git/index'".
+
+Fix the issue by using `$(wildcard .git/index)`. In case the file
+exists, we will pick it up as a dependency of "version.h" and
+thus recompile it whenever the git repo changes. Otherwise, the
+wildcard won't match and we will fall back to just using the
+declared value of the "version" variable.
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index fa75f10..de5c4d5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,7 @@ include config.mk
+
+ all: version.h src.subdir-all
+
+-version.h: Makefile .git/index
++version.h: Makefile $(wildcard .git/index)
+ @echo "create $@"
+ $(Q)v="$$(git describe --tags 2>/dev/null)"; \
+ echo "#define VERSION \"$${v:-$(version)}\"" > $@
+--
+2.21.0
+
diff --git a/PKGBUILD b/PKGBUILD
index fb54e2e1fce7..41228d0983f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
# Maintainer: Robert Timm <mail@rtti.de>
pkgname=vimb
-pkgver=3.3.0
-pkgrel=2
+pkgver=3.4.0
+pkgrel=1
epoch=
arch=('i686' 'x86_64')
pkgdesc="The vim like browser"
url="http://fanglingsu.github.io/vimb"
license=('GPLv3')
-depends=('webkit2gtk>=2.8', 'pkgconf')
+depends=('webkit2gtk>=2.20', 'pkgconf')
provides=('vimb')
conflicts=('vimb2' 'vimb-gtk2' 'vimb-git')
-source=('vimb-3.3.0.tar.gz::https://github.com/fanglingsu/vimb/archive/3.3.0.tar.gz')
-md5sums=('b6e69c0efc5546bdc91453741ff25a90')
-sha256sums=('5c6fe39b1b2ca18a342bb6683f7fd5b139ead53903f57dd9eecd5a1074576d6c')
+source=("vimb-$pkgver.tar.gz::https://github.com/fanglingsu/vimb/archive/$pkgver.tar.gz" 0001-Makefile-fix-compilation-if-source-is-not-in-a-git-r.patch)
+md5sums=('befacbb3089627a516cf8f12ac389b98' '0899d1692c08b261bc576ed354acf797')
+sha256sums=('36838f509a2ec55515eaf51bbe8c4885f3ef20847f0f42d36103dcfddaf5b39a' '15b6fedc1612088d74e8699dac440ffa0ae80ed81a93c5d871437b521236563d')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@@ -23,6 +23,7 @@ prepare() {
msg "Using custom config.h";
cp $SRCDEST/config.h "$srcdir/$pkgname/src"
fi
+ patch -Np1 < ../../0001-Makefile-fix-compilation-if-source-is-not-in-a-git-r.patch
}
build() {