summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2017-06-09 06:34:36 +0200
committeraksr2017-06-09 06:35:07 +0200
commit451e5353d63b945a33af19421005af3c407fb017 (patch)
treeea3a2d275bc08594721a769b0cb3fc93ca49e7b2
parent45eba43b45ef3000dc30d312bb2c5d44f0429b87 (diff)
downloadaur-451e5353d63b945a33af19421005af3c407fb017.tar.gz
Update.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD52
2 files changed, 45 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c60079e1c310..94d424569b25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Jun 9 04:33:58 UTC 2017
pkgbase = vimb-git
- pkgdesc = Vimb is a lightweight WebKit-based browser
- pkgver = 2.10.r6.g1a8f7e5
+ pkgdesc = A Vim-like web browser that is inspired by Pentadactyl and Vimprobable.
+ pkgver = 3.0.r1426.782acb5
pkgrel = 1
url = http://fanglingsu.github.io/vimb
arch = i686
arch = x86_64
- license = GPL3
- depends = webkitgtk2
+ license = GPLv3
+ makedepends = git
+ depends = webkit2gtk>=2.8
provides = vimb
conflicts = vimb
- source = git+https://github.com/fanglingsu/vimb.git
+ conflicts = vimb2
+ source = vimb-git::git+https://github.com/fanglingsu/vimb.git
md5sums = SKIP
pkgname = vimb-git
diff --git a/PKGBUILD b/PKGBUILD
index d4dab7b55b31..14fd167fcd3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,52 @@
-# Maintainer: jason ryan <jasonwryan@gmail.com>
-
+# Contributor: jason ryan <jasonwryan@gmail.com>
+# Contributor: fanglingsu
+# Maintainer: <aksr at t-com dot me>
pkgname=vimb-git
-_pkgname=vimb
-pkgver=2.10.r6.g1a8f7e5
+pkgver=3.0.r1426.782acb5
pkgrel=1
-pkgdesc="Vimb is a lightweight WebKit-based browser"
+epoch=
arch=('i686' 'x86_64')
+pkgdesc="A Vim-like web browser that is inspired by Pentadactyl and Vimprobable."
+url="https://github.com/fanglingsu/vimb"
url="http://fanglingsu.github.io/vimb"
-license=('GPL3')
-depends=('webkitgtk2')
+license=('GPLv3')
+depends=('webkit2gtk>=2.8')
+makedepends=('git')
+optdepends=()
+checkdepends=()
provides=('vimb')
-conflicts=('vimb')
-source=('git+https://github.com/fanglingsu/vimb.git')
+conflicts=('vimb' 'vimb2')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/fanglingsu/vimb.git")
+noextract=()
md5sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/$pkgname"
+ printf "%s.r%s.%s" "$(git describe --long --tags | sed -e 's/-alpha/.0/' -e 's/-.*//')" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ if [ -e $SRCDEST/config.h ]; then
+ msg "Using custom config.h";
+ cp $SRCDEST/config.h "$srcdir/$pkgname/src"
+ fi
}
build() {
- cd "${_pkgname}"
- make
+ cd "$srcdir/$pkgname"
+ make V=1
}
package() {
- cd "${_pkgname}"
- make DESTDIR="$pkgdir" PREFIX="/usr" install
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-# vim:set ts=2 sw=2 et: