summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-11-13 00:39:45 +0100
committerbegin-theadventure2023-11-13 00:39:45 +0100
commit3f05197bd24e0eb057af56523af3c5ad47953a58 (patch)
treec4c3b7610efd3140cfb34063754aa1aba84910f7
parent069c0d0e2504abe9d476c8cc3351ae70cc07d63d (diff)
downloadaur-vimcdoc.tar.gz
2.4.0, cleanup
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD49
2 files changed, 33 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 783cca64944d..b1b881fad666 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = vimcdoc
- pkgdesc = Vim chinese documentation
- pkgver = 2.3.0
+ pkgdesc = Vim Chinese Documentation
+ pkgver = 2.4.0
pkgrel = 1
url = http://vimcdoc.sf.net
arch = any
- license = GPL
+ license = custom:vimcdoc
depends = vim
- source = https://nchc.dl.sourceforge.net/project/vimcdoc/vimcdoc/vimcdoc-2.3.0.tar.gz
- md5sums = fdc9e9d35a1355423bcc5f75f7f5463c
+ source = https://nchc.dl.sourceforge.net/project/vimcdoc/vimcdoc/vimcdoc-2.4.0.tar.gz
+ sha256sums = 08f7fb85dc5c7d2535749336d0268262d3a6be213a8bdf2d0de90073be187046
pkgname = vimcdoc
diff --git a/PKGBUILD b/PKGBUILD
index aeb85e4aa45f..8ebb26ed76a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,33 @@
-# Maintainer: nb5p
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+# Contributor: nb5p
+
pkgname=vimcdoc
-pkgver=2.3.0
+pkgver=2.4.0
pkgrel=1
-pkgdesc="Vim chinese documentation"
-arch=(any)
-depends=('vim')
+pkgdesc="Vim Chinese Documentation"
url="http://vimcdoc.sf.net"
-license=('GPL')
-source=("https://nchc.dl.sourceforge.net/project/vimcdoc/vimcdoc/vimcdoc-2.3.0.tar.gz")
-md5sums=('fdc9e9d35a1355423bcc5f75f7f5463c')
+url2="http://github.com/yianwillis/vimcdoc"
+arch=('any')
+license=('custom:vimcdoc')
+depends=('vim')
+source=("https://nchc.dl.sourceforge.net/project/vimcdoc/vimcdoc/vimcdoc-$pkgver.tar.gz")
+sha256sums=('08f7fb85dc5c7d2535749336d0268262d3a6be213a8bdf2d0de90073be187046')
+
package() {
- cd "${pkgname}-${pkgver}"
- local _dir="${pkgdir}/usr/share/vim/vimfiles"
- for __dir in *; do
- if [ -d "${__dir}" ]; then
- cd ${__dir}
- for __file in *; do
- if [ -f "${__file}" ]; then
- install -Dm 644 ${__file} ${_dir}/${__dir}/${__file}
- fi
- done
- cd ..
- fi
- done
+ cd vimcdoc-$pkgver
+ local _dir="$pkgdir/usr/share/vim/vimfiles"
+ for __dir in *; do
+ if [ -d "${__dir}" ]; then
+ cd ${__dir}
+ for __file in *; do
+ if [ -f "${__file}" ]; then
+ install -Dm644 ${__file} ${_dir}/${__dir}/${__file}
+ fi
+ done
+ cd ..
+ fi
+ done
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/vimcdoc"
+ rm -dr doc plugin syntax LICENSE VERSION vimcdoc.sh
+ install -Dm644 * -t "$pkgdir/usr/share/doc/vimcdoc"
}