summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryesuu2015-07-08 12:44:54 +0800
committeryesuu2015-07-08 12:44:54 +0800
commite63500908b2fa29397552080a50eec2590badcd3 (patch)
tree737cbdcfaadb37d73d1a059344d0cf34e03a9b34
downloadaur-e63500908b2fa29397552080a50eec2590badcd3.tar.gz
first commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..403d773dae39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vimim
+ pkgdesc = The VimIM is a Vim plugin designed as an independent IM (Input Method) to support CJK search and CJK input, with or without vim omni popup window.
+ pkgver = 1.0.0.1
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=2506
+ arch = any
+ groups = vim-plugins
+ license = GPL
+ depends = vim>=7.0
+ source = vimim.vim::http://www.vim.org/scripts/download_script.php?src_id=23122
+ md5sums = d76596281165b27194c965c2eb73a6e0
+
+pkgname = vimim
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33a23e732b28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: yesuu zhang <yesuu79@qq.com>
+# Contributor: cap_sensitive <cap.sensitive@gmail.com>
+
+pkgname=vimim
+pkgver=1.0.0.1
+pkgrel=1
+pkgdesc='The VimIM is a Vim plugin designed as an independent IM (Input Method) to support CJK search and CJK input, with or without vim omni popup window.'
+arch=('any')
+url='http://www.vim.org/scripts/script.php?script_id=2506'
+license=('GPL')
+groups=('vim-plugins')
+depends=('vim>=7.0')
+source=('vimim.vim::http://www.vim.org/scripts/download_script.php?src_id=23122')
+md5sums=('d76596281165b27194c965c2eb73a6e0')
+
+package() {
+ cd ${srcdir}
+ install --directory "${pkgdir}/usr/share/vim/vimfiles/plugin"
+ cp vimim.vim "${pkgdir}/usr/share/vim/vimfiles/plugin"
+}