summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkarlch2015-12-02 23:49:27 +0100
committerkarlch2015-12-02 23:49:27 +0100
commitfaf1b501b14ae102dca672a38d3707d6265a5d0c (patch)
treefeb5fb0122905e8964abde13d02cda5d1404f2c5
downloadaur-faf1b501b14ae102dca672a38d3707d6265a5d0c.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d601c2507dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vimiv-git
+ pkgdesc = An image viewer with vim-like keybindings
+ pkgver = 305af42
+ pkgrel = 1
+ url = https://github.com/karlch/vimiv
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python3
+ depends = python-gobject
+ depends = gtk3
+ depends = python-pillow
+ optdepends = imagemagick: for the optimization of images
+ provides = vimiv-git
+ source = vimiv-git::git+https://github.com/karlch/vimiv.git
+ md5sums = SKIP
+
+pkgname = vimiv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f542ccf85e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Christian Karl <christian.karl@protonmail.com>
+
+pkgname='vimiv-git'
+pkgrel=1
+pkgver=305af42
+pkgdesc="An image viewer with vim-like keybindings"
+arch=('any')
+url="https://github.com/karlch/vimiv"
+license=('MIT')
+depends=('python3' 'python-gobject' 'gtk3' 'python-pillow')
+makedepends=('git')
+optdepends=('imagemagick: for the optimization of images')
+provides=('vimiv-git')
+source=("$pkgname::git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ install -D -m755 vimiv $pkgdir/usr/bin/vimiv
+ install -D -m644 vimivrc.py $pkgdir/etc/vimiv/vimivrc.py
+ install -D -m644 vimiv.desktop $pkgdir/usr/share/applications/vimiv.desktop
+ install -D -m644 LICENSE $pkgdir/usr/share/licenses/vimiv/LICENSE
+ install -D -m644 vimiv.1 $pkgdir/usr/share/man/man1/vimiv.1
+}