aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrent Palmer2018-06-10 17:43:18 -0700
committerTrent Palmer2018-06-10 17:43:18 -0700
commit990c71fd2f2998ee77e200dedf8797f86eb7d8e2 (patch)
tree574727ad9e1c01a3c32cd3c861a042076137acf0
parentebbe2383c53007cafd5e7b9ce183a45b95cd834e (diff)
downloadaur-vimscripts-autoclose.tar.gz
set default option to not install to /usr/share/nvim
because latest neovim finds plugins in /usr/share/vim/vimfiles
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
-rw-r--r--README.md3
3 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf9cdd23c727..eb7dbf787682 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vimscripts-autoclose
pkgdesc = plugin that automatically closes quote, parentheses, brackets, braces, etc
pkgver = 1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vim-scripts/AutoClose
arch = any
license = unknown
diff --git a/PKGBUILD b/PKGBUILD
index 53d07b844be3..aac6c42ab0aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,18 @@
# Maintainer: Trent Palmer trenttdually at gmail
+###########################################################################################################
+# Build Options
+###########################################################################################################
+_vim="y"
+
+# if you have a newer version of neovim you may not need or want to set _neovim="y"
+_neovim="n"
+###########################################################################################################
+
pkgname='vimscripts-autoclose'
_srcpkgname='AutoClose'
pkgver=1.2
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="plugin that automatically closes quote, parentheses, brackets, braces, etc"
arch=('any')
@@ -27,13 +36,17 @@ md5sums=('8eb8630367d6978f3e2696df27eff4eb')
validpgpkeys=()
package() {
+ if [ "$_neovim" = "y" ]; then
mkdir -p "$pkgdir/usr/share/nvim/runtime"
cp -r "${srcdir}/${_srcpkgname}-${pkgver}/plugin" \
"$pkgdir/usr/share/nvim/runtime"
+ fi
+ if [ "$_vim" = "y" ]; then
mkdir -p "$pkgdir/usr/share/vim/vimfiles"
cp -r "${srcdir}/${_srcpkgname}-${pkgver}/plugin" \
"$pkgdir/usr/share/vim/vimfiles"
+ fi
install -D -m644 "${srcdir}/${_srcpkgname}-${pkgver}/README" $pkgdir/usr/share/doc/$pkgname/README
}
diff --git a/README.md b/README.md
index 1acd77871d9d..109674d3eda2 100644
--- a/README.md
+++ b/README.md
@@ -1,2 +1,3 @@
### Dual-Purpose
-PKGBUILD modified to work with both vim and neovim
+PKGBUILD modified to work with both vim and neovim, however newer versions of neovim
+will load plugins from /usr/share/vim/vimfiles