summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEcho J.2023-09-26 13:40:58 +0300
committerEcho J.2023-09-26 13:40:58 +0300
commit1aa2b046e803ad294fed24e1075cf735a32a46c4 (patch)
tree6a2b2daabe239db97284228005837f1345d4a5c8
parente235e04944e440a396f6793eb800617ec228c4dc (diff)
downloadaur-1aa2b046e803ad294fed24e1075cf735a32a46c4.tar.gz
Update to 1.4.3
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6bcf52fc544..1a86111ff812 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vinegar
pkgdesc = A transparent wrapper for Roblox Player and Roblox Studio
- pkgver = 1.4.2
+ pkgver = 1.4.3
pkgrel = 1
url = https://github.com/vinegarhq/vinegar
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = vinegar
depends = hicolor-icon-theme
optdepends = wine: A required dependency (made optional for flexbility)
conflicts = vinegar-git
- source = vinegar-1.4.2.tar.gz::https://github.com/vinegarhq/vinegar/archive/v1.4.2.tar.gz
- sha256sums = eb3476b8de6a76b585206bb5fe901d74980de24b3c5c8e4c59598b0b25276f2b
+ source = https://github.com/vinegarhq/vinegar/releases/download/v1.4.3/vinegar-v1.4.3.tar.xz
+ sha256sums = d55987d0f4a5175be8e8da98600fbc99c07b94f5c349f50199f4f69a70f7f156
pkgname = vinegar
diff --git a/.gitignore b/.gitignore
index 85d98b657ea1..bdfdab31c0e2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ pkg/
src/
*.pkg.tar.zst
*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index e0651189e00a..7b24630d2cef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Note: I hope wael is a nice woman now :troll:
pkgname=vinegar
-pkgver=1.4.2
+pkgver=1.4.3
pkgrel=1
pkgdesc="A transparent wrapper for Roblox Player and Roblox Studio"
arch=("x86_64")
@@ -14,11 +14,11 @@ depends=("glibc" "hicolor-icon-theme")
makedepends=("git" "go")
optdepends=("wine: A required dependency (made optional for flexbility)")
conflicts=("vinegar-git")
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=("eb3476b8de6a76b585206bb5fe901d74980de24b3c5c8e4c59598b0b25276f2b")
+source=("${url}/releases/download/v${pkgver}/${pkgname}-v${pkgver}.tar.xz")
+sha256sums=("d55987d0f4a5175be8e8da98600fbc99c07b94f5c349f50199f4f69a70f7f156")
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-v${pkgver}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -modcacherw"
@@ -29,7 +29,7 @@ build() {
}
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-v${pkgver}"
# This does all the work (except for the optional LICENSE file)
make DESTDIR="${pkgdir}" PREFIX="/usr" install