summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEcho J2023-04-14 23:14:33 +0300
committerEcho J2023-04-14 23:14:33 +0300
commit378cdd1b9494b32d74a4ed9e90444d1cf1b78ea4 (patch)
treeaed1f050f33b04da9ebaee79c142fcd535de32a5
parentffc486fc1fefbe55490c020053a4e9c7b5c04528 (diff)
downloadaur-378cdd1b9494b32d74a4ed9e90444d1cf1b78ea4.tar.gz
Hotfix for .desktop files
I just noticed that the .desktop files have broken MIME stuff (as I said, Vinegar is a mess) I should probably upstream this (but I'm not sure if Vinegar is a good project anymore)
-rw-r--r--PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94547ded872c..0dce7bd039ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,6 +35,17 @@ package() {
# This does all the work (except for the optional LICENSE file)
make VERSION="${pkgver}" DESTDIR="${pkgdir}" PREFIX="/usr" install
+ # Fix up the .desktop files (as I expected, Vinegar is a mess)
+ _player=io.github.vinegarhq.Vinegar.player.desktop
+ _studio=io.github.vinegarhq.Vinegar.studio.desktop
+ _playermime="x-scheme-handler/roblox;x-scheme-handler/roblox-player;"
+ _studiomime="application/x-roblox-rbxl;application/x-roblox-rbxlx;x-scheme-handler/roblox-studio;x-scheme-handler/roblox-studio-auth;"
+
+ desktop-file-edit --remove-key="MimeType" "${pkgdir}/usr/share/applications/${_player}"
+ desktop-file-edit --remove-key="MimeType" "${pkgdir}/usr/share/applications/${_studio}"
+ desktop-file-edit --set-key="MimeType" --set-value="${_playermime}" "${pkgdir}/usr/share/applications/${_player}"
+ desktop-file-edit --set-key="MimeType" --set-value="${_studiomime}" "${pkgdir}/usr/share/applications/${_studio}"
+
# Install GPLv3 license (just in case)
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}