summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorimskyyc2024-02-17 16:33:03 -0800
committerimskyyc2024-02-17 16:33:03 -0800
commit4291c866ec8798b306db7afa9806eaaa7c8914e9 (patch)
tree0dc3b6a1ca7b0cade196987db45b2fb5f116b3b5
parent85efa57dcf9df7ee833ae9dd0e8ed079bf070c1b (diff)
downloadaur-4291c866ec8798b306db7afa9806eaaa7c8914e9.tar.gz
update PKGBUILD for version 1.7.3-3
-rw-r--r--PKGBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2302af46ce5..afd90e08ea3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
pkgname=vinegar
pkgver=1.7.3
-pkgrel=2
-pkgdesc="A launcher for Roblox Player and Studio"
+pkgrel=3
+pkgdesc="Fast and robust bootstrapper for Roblox that has many ease-of-use features."
arch=("x86_64")
-url="https://github.com/vinegarhq/vinegar"
+url="https://vinegarhq.org"
license=("GPL-3.0-only")
depends=("glibc" "hicolor-icon-theme" "libgles" "libxcursor" "libxfixes"
"libxkbcommon" "libxkbcommon-x11" "libx11" "wayland")
@@ -15,26 +15,22 @@ optdepends=("gamemode: Gamemode integration"
"vulkan-driver: Vulkan support in GUI"
"wine: A required dependency (made optional for flexbility)")
conflicts=("vinegar-git")
-source=("${url}/releases/download/v${pkgver}/${pkgname}-v${pkgver}.tar.xz")
+source=("https://github.com/vinegarhq/vinegar/releases/download/v${pkgver}/${pkgname}-v${pkgver}.tar.xz")
sha256sums=("6d8cf5f4fea17560c7cca601ad4da6ed305318e27d00d8e9589d0a9407632aeb")
prepare() {
cd "${pkgname}-v${pkgver}"
-
- # Disable a malicious feature
- sed -i 's/_, err := os.Stat(dirs.Prefix); err == nil/false/' cmd/vinegar/main.go
+ make clean
}
build() {
cd "${pkgname}-v${pkgver}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -modcacherw"
-
- # Needed for RELRO support (which is a security feature)
export CGO_LDFLAGS="${LDFLAGS}"
-
- # Make sure Vinegar rebuilds
- make clean
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
make DESTDIR="${pkgdir}" PREFIX="/usr" all
}
@@ -42,9 +38,6 @@ build() {
package() {
cd "${pkgname}-v${pkgver}"
- # This does all the work (except for the optional LICENSE file)
make DESTDIR="${pkgdir}" PREFIX="/usr" install
-
- # Install GPLv3 license (just in case)
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}