summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEcho J2023-05-11 18:19:22 +0300
committerEcho J2023-07-24 16:13:32 +0300
commit6f1a7a6535ad138f110a9c98138c4e69725641d5 (patch)
treea76eab63b39ac760242a88b920c85cbc19aed65d
parent1495e7c6d56773cda9fdb379b3559cf0029457d5 (diff)
downloadaur-6f1a7a6535ad138f110a9c98138c4e69725641d5.tar.gz
Remove the obsolete hack
-rw-r--r--PKGBUILD11
1 files changed, 0 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1b5fcd1607a..565ae4128877 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,17 +30,6 @@ package() {
# This does all the work (except for the optional LICENSE file)
make VERSION="${pkgver}" DESTDIR="${pkgdir}" PREFIX="/usr" install
- # Fix up the .desktop files (as I expected, Vinegar is a mess)
- _player=io.github.vinegarhq.Vinegar.player.desktop
- _studio=io.github.vinegarhq.Vinegar.studio.desktop
- _playermime="x-scheme-handler/roblox;x-scheme-handler/roblox-player;"
- _studiomime="application/x-roblox-rbxl;application/x-roblox-rbxlx;x-scheme-handler/roblox-studio;x-scheme-handler/roblox-studio-auth;"
-
- desktop-file-edit --remove-key="MimeType" "${pkgdir}/usr/share/applications/${_player}"
- desktop-file-edit --remove-key="MimeType" "${pkgdir}/usr/share/applications/${_studio}"
- desktop-file-edit --set-key="MimeType" --set-value="${_playermime}" "${pkgdir}/usr/share/applications/${_player}"
- desktop-file-edit --set-key="MimeType" --set-value="${_studiomime}" "${pkgdir}/usr/share/applications/${_studio}"
-
# Install GPLv3 license (just in case)
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}