summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEcho J.2023-12-23 14:39:26 +0200
committerEcho J.2023-12-23 14:39:26 +0200
commit2e5faa3954e3fa7080ec8d124e6c788f0b93807a (patch)
treebceee40fa6cf02c7989011a32d5e0461c3c14ee1
parent99d313512c93b5472f221ded9690fb8d05579b7c (diff)
downloadaur-2e5faa3954e3fa7080ec8d124e6c788f0b93807a.tar.gz
Add a hack for icons
Also pull the changes from regular vinegar package
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66d2166cc983..f7cead722ef0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vinegar-git
pkgdesc = A transparent wrapper for Roblox Player and Roblox Studio (Git version)
- pkgver = 1.5.0.r0.gd6d1f74
+ pkgver = 1.6.0.r1.gc3160de
pkgrel = 1
url = https://github.com/vinegarhq/vinegar
arch = x86_64
@@ -18,6 +18,7 @@ pkgbase = vinegar-git
depends = libxkbcommon-x11
depends = libx11
depends = wayland
+ optdepends = gamemode: Gamemode integration
optdepends = vulkan-driver: Vulkan support in GUI
optdepends = wine: A required dependency (made optional for flexbility)
conflicts = vinegar
diff --git a/PKGBUILD b/PKGBUILD
index 18ee35388721..0c87c90e3b00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=vinegar
pkgname=vinegar-git
-pkgver=1.5.0.r0.gd6d1f74
+pkgver=1.6.0.r1.gc3160de
pkgrel=1
pkgdesc="A transparent wrapper for Roblox Player and Roblox Studio (Git version)"
arch=("x86_64")
@@ -14,12 +14,21 @@ license=("GPL3")
depends=("glibc" "hicolor-icon-theme" "libgles" "libxcursor" "libxfixes"
"libxkbcommon" "libxkbcommon-x11" "libx11" "wayland")
makedepends=("git" "go" "vulkan-headers" "wayland-protocols")
-optdepends=("vulkan-driver: Vulkan support in GUI"
+optdepends=("gamemode: Gamemode integration"
+ "vulkan-driver: Vulkan support in GUI"
"wine: A required dependency (made optional for flexbility)")
conflicts=("vinegar")
source=("git+${url}")
sha256sums=("SKIP")
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ # HACK (FIXME): Don't rebuild the icons when installing them
+ # (upstream repo has them anyway and building them causes race conditions)
+ sed -i 's/install-icons: icons/install-icons:/' Makefile
+}
+
pkgver() {
cd "${srcdir}/${_pkgname}"
git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
@@ -36,8 +45,7 @@ build() {
# Make sure Vinegar rebuilds
make clean
- # Enable all Gio features (overriding default upstream behavior)
- make VINEGAR_GOFLAGS="" DESTDIR="${pkgdir}" PREFIX="/usr" all
+ make DESTDIR="${pkgdir}" PREFIX="/usr" all
}
package() {