summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEcho J.2023-09-05 15:34:58 +0300
committerEcho J.2023-09-05 15:34:58 +0300
commit6d351e1c1750a06954724ff2b60b886613eab86e (patch)
tree014b615c5132a97aa90f70c42d77c1a960e150c6
parent6b6ed9a68a1cb78490ce580894a5c73ebcf5585c (diff)
downloadaur-6d351e1c1750a06954724ff2b60b886613eab86e.tar.gz
Update the make targets
Also remove the MinGW GCC dependency (because robloxmutexer is built with the Go toolchain now)
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8e22d372b56..39ddf58dd19a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = vinegar-git
pkgdesc = A transparent wrapper for Roblox Player and Roblox Studio (Git version)
- pkgver = 1.1.0.r1.ge4e8951
+ pkgver = 1.4.1.r13.gf3a248e
pkgrel = 1
url = https://github.com/vinegarhq/vinegar
arch = x86_64
license = GPL3
makedepends = git
makedepends = go
- makedepends = mingw-w64-gcc
depends = glibc
depends = hicolor-icon-theme
optdepends = wine: A required dependency (made optional for flexbility)
diff --git a/PKGBUILD b/PKGBUILD
index 687c904c381a..8d477367e94c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
_pkgname=vinegar
pkgname=vinegar-git
-pkgver=1.1.0.r1.ge4e8951
+pkgver=1.4.1.r13.gf3a248e
pkgrel=1
pkgdesc="A transparent wrapper for Roblox Player and Roblox Studio (Git version)"
arch=("x86_64")
url="https://github.com/vinegarhq/vinegar"
license=("GPL3")
depends=("glibc" "hicolor-icon-theme")
-makedepends=("git" "go" "mingw-w64-gcc")
+makedepends=("git" "go")
optdepends=("wine: A required dependency (made optional for flexbility)")
conflicts=("vinegar")
source=("git+${url}")
@@ -31,14 +31,14 @@ build() {
# Make sure Vinegar rebuilds
make clean
- make DESTDIR="${pkgdir}" PREFIX="/usr" vinegar robloxmutexer
+ make DESTDIR="${pkgdir}" PREFIX="/usr" all
}
package() {
cd "${srcdir}/${_pkgname}"
# This does all the work (except for the optional LICENSE file)
- make DESTDIR="${pkgdir}" PREFIX="/usr" install install-robloxmutexer
+ make DESTDIR="${pkgdir}" PREFIX="/usr" install
# Install GPLv3 license (just in case)
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"