summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEcho J2024-02-17 10:28:34 +0200
committerEcho J2024-02-17 10:28:34 +0200
commit7c64f99add30686cecc0f7f77c906c2f47db5f37 (patch)
treefb1aa1fdd2c2be57c1458f59d8815a6c6951d981
parent3e650d74ad3df00cd94ef6af147cc1086615b0a8 (diff)
downloadaur-7c64f99add30686cecc0f7f77c906c2f47db5f37.tar.gz
Add some things
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
-rw-r--r--vinegar-git.install11
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98bd6f81b3dd..00ff469a15a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = vinegar-git
- pkgdesc = A transparent wrapper for Roblox Player and Roblox Studio (Git version)
- pkgver = 1.6.1.r0.g6545e22
+ pkgdesc = A weirdo launcher for Roblox Player and Studio (Git version)
+ pkgver = 1.7.3.r8.gcd7faa4
pkgrel = 1
url = https://github.com/vinegarhq/vinegar
+ install = vinegar-git.install
arch = x86_64
license = GPL-3.0-only
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 4f30f5563ce3..a149f9f2e3f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
_pkgname=vinegar
pkgname=vinegar-git
-pkgver=1.6.1.r0.g6545e22
+pkgver=1.7.3.r8.gcd7faa4
pkgrel=1
-pkgdesc="A transparent wrapper for Roblox Player and Roblox Studio (Git version)"
+pkgdesc="A weirdo launcher for Roblox Player and Studio (Git version)"
arch=("x86_64")
url="https://github.com/vinegarhq/vinegar"
license=("GPL-3.0-only")
@@ -18,6 +18,7 @@ optdepends=("gamemode: Gamemode integration"
conflicts=("vinegar")
source=("git+${url}")
sha256sums=("SKIP")
+install="${pkgname}.install"
prepare() {
cd "${srcdir}/${_pkgname}"
@@ -25,6 +26,9 @@ prepare() {
# HACK (FIXME): Don't rebuild the icons when installing them
# (upstream repo has them anyway and building them causes race conditions)
sed -i 's/install-icons: icons/install-icons:/' Makefile
+
+ # Disable a malicious feature
+ sed -i 's/_, err := os.Stat(dirs.Prefix); err == nil/false/' cmd/vinegar/main.go
}
pkgver() {
diff --git a/vinegar-git.install b/vinegar-git.install
new file mode 100644
index 000000000000..c2759c3ecffa
--- /dev/null
+++ b/vinegar-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ if (! pacman -Q grapejuice &>/dev/null) && (! flatpak info net.brinkervii.grapejuice &>/dev/null); then
+ for i in {0..2}; do
+ echo -e "\033[1;33muse grapejuice\033[0m"
+ done
+ fi
+}
+
+post_upgrade() {
+ post_install
+}