summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEcho J.2023-10-07 20:48:09 +0300
committerEcho J.2023-10-07 20:48:09 +0300
commit99d313512c93b5472f221ded9690fb8d05579b7c (patch)
tree37de2c23a39ad40e7d1f363bda7e223ed318c70c
parent6d351e1c1750a06954724ff2b60b886613eab86e (diff)
downloadaur-99d313512c93b5472f221ded9690fb8d05579b7c.tar.gz
Add GUI stuff
Also enable RELRO support (apparently the CGO variable is actually needed)
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39ddf58dd19a..66d2166cc983 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,24 @@
pkgbase = vinegar-git
pkgdesc = A transparent wrapper for Roblox Player and Roblox Studio (Git version)
- pkgver = 1.4.1.r13.gf3a248e
+ pkgver = 1.5.0.r0.gd6d1f74
pkgrel = 1
url = https://github.com/vinegarhq/vinegar
arch = x86_64
license = GPL3
makedepends = git
makedepends = go
+ makedepends = vulkan-headers
+ makedepends = wayland-protocols
depends = glibc
depends = hicolor-icon-theme
+ depends = libgles
+ depends = libxcursor
+ depends = libxfixes
+ depends = libxkbcommon
+ depends = libxkbcommon-x11
+ depends = libx11
+ depends = wayland
+ optdepends = vulkan-driver: Vulkan support in GUI
optdepends = wine: A required dependency (made optional for flexbility)
conflicts = vinegar
source = git+https://github.com/vinegarhq/vinegar
diff --git a/PKGBUILD b/PKGBUILD
index 8d477367e94c..18ee35388721 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,17 @@
_pkgname=vinegar
pkgname=vinegar-git
-pkgver=1.4.1.r13.gf3a248e
+pkgver=1.5.0.r0.gd6d1f74
pkgrel=1
pkgdesc="A transparent wrapper for Roblox Player and Roblox Studio (Git version)"
arch=("x86_64")
url="https://github.com/vinegarhq/vinegar"
license=("GPL3")
-depends=("glibc" "hicolor-icon-theme")
-makedepends=("git" "go")
-optdepends=("wine: A required dependency (made optional for flexbility)")
+depends=("glibc" "hicolor-icon-theme" "libgles" "libxcursor" "libxfixes"
+ "libxkbcommon" "libxkbcommon-x11" "libx11" "wayland")
+makedepends=("git" "go" "vulkan-headers" "wayland-protocols")
+optdepends=("vulkan-driver: Vulkan support in GUI"
+ "wine: A required dependency (made optional for flexbility)")
conflicts=("vinegar")
source=("git+${url}")
sha256sums=("SKIP")
@@ -28,10 +30,14 @@ build() {
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -modcacherw"
+ # Needed for RELRO support (which is a security feature)
+ export CGO_LDFLAGS="${LDFLAGS}"
+
# Make sure Vinegar rebuilds
make clean
- make DESTDIR="${pkgdir}" PREFIX="/usr" all
+ # Enable all Gio features (overriding default upstream behavior)
+ make VINEGAR_GOFLAGS="" DESTDIR="${pkgdir}" PREFIX="/usr" all
}
package() {