summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorimskyyc2024-03-16 20:34:20 -0700
committerimskyyc2024-03-16 20:34:20 -0700
commitcbf0204fbe691dbf39bdb72e5bcdd361ee53a5fe (patch)
tree9b152afcce5d039361a2c3d848fb911a83cfb456
parentf57c75e3ab5ac8c1dcd8fa9a137462c508d5c1e9 (diff)
downloadaur-cbf0204fbe691dbf39bdb72e5bcdd361ee53a5fe.tar.gz
update pkgver and add pkgver() function
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cba59789d330..b27d66c6623a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vinegar-git
pkgdesc = Fast and robust bootstrapper for Roblox that has many ease-of-use features.
- pkgver = 1.7.4.r1.g837cda9
+ pkgver = v1.7.4.r21.gbe39c40
pkgrel = 1
url = https://github.com/vinegarhq/vinegar
arch = x86_64
@@ -21,7 +21,7 @@ pkgbase = vinegar-git
optdepends = gamemode: Gamemode integration
optdepends = vulkan-driver: Vulkan support in GUI
optdepends = wine: A required dependency (made optional for flexbility)
- provides = vinegar-git=1.7.4.r1.g837cda9
+ provides = vinegar-git=v1.7.4.r21.gbe39c40
conflicts = vinegar
source = git+https://github.com/vinegarhq/vinegar
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 03177ef0e224..c8ae2072c0e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=vinegar
pkgname=vinegar-git
-pkgver=1.7.4.r1.g837cda9
pkgrel=1
+pkgver=v1.7.4.r21.gbe39c40
pkgdesc="Fast and robust bootstrapper for Roblox that has many ease-of-use features."
arch=("x86_64")
url="https://github.com/vinegarhq/vinegar"
@@ -20,6 +20,12 @@ source=("git+${url}")
sha256sums=("SKIP")
provides=("${pkgname}=${pkgver}");
+pkgver() {
+ cd "$_pkgname"
+ # cutting off 'foo-' prefix that presents in the git tag
+ git describe --long --abbrev=7 | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
cd "${srcdir}/${_pkgname}"