summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 22:02:08 +0200
committeroli2015-06-12 22:02:08 +0200
commitcc6695cc841f82e21f68479dabc72e7c89317efb (patch)
tree2f7844c3b07cc06512117db44725db1731b0dc5a
downloadaur-cc6695cc841f82e21f68479dabc72e7c89317efb.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
-rw-r--r--vinetto-hashlib.patch53
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2b482420781
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vinetto
+ pkgdesc = a forensics tool to examine Thumbs.db files
+ pkgver = 0.07beta
+ pkgrel = 6
+ url = http://vinetto.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL-2
+ depends = python2
+ depends = python2-pillow
+ source = vinetto-hashlib.patch
+ source = http://downloads.sourceforge.net/vinetto/vinetto-beta-0.07.tar.gz
+ md5sums = dad52b1380f3a4e04ceac2e981237361
+ md5sums = 3bfab4eaacde52a66a6829dddc7511cc
+ sha1sums = 01f70e032c17d3a90cd17244432a731ba01d3726
+ sha1sums = 5f53a4ce6985a7d6a387c09d79038124d88b796e
+
+pkgname = vinetto
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b825a8c1fa9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jozef Riha <jose1711 at gmail dot com>
+# Contributor: snuo
+
+pkgname=vinetto
+pkgver=0.07beta
+pkgrel=6
+pkgdesc="a forensics tool to examine Thumbs.db files"
+url="http://vinetto.sourceforge.net"
+license="GPL-2"
+arch=('i686' 'x86_64')
+depends=('python2' 'python2-pillow')
+source=("vinetto-hashlib.patch"
+ "http://downloads.sourceforge.net/$pkgname/$pkgname-beta-0.07.tar.gz")
+md5sums=('dad52b1380f3a4e04ceac2e981237361'
+ '3bfab4eaacde52a66a6829dddc7511cc')
+sha1sums=('01f70e032c17d3a90cd17244432a731ba01d3726'
+ '5f53a4ce6985a7d6a387c09d79038124d88b796e')
+
+package() {
+ cd $srcdir/$pkgname-beta-0.07
+ patch -i ../vinetto-hashlib.patch $srcdir/$pkgname-beta-0.07/vinetto
+ python2 setup.py install --root=$pkgdir/ --prefix=/usr
+}
diff --git a/vinetto-hashlib.patch b/vinetto-hashlib.patch
new file mode 100644
index 000000000000..2795047a86cc
--- /dev/null
+++ b/vinetto-hashlib.patch
@@ -0,0 +1,53 @@
+--- vinetto
++++ vinetto
+***************
+*** 32,38 ****
+ import sys
+ import os
+ import StringIO
+! import md5
+ import vinreport
+
+ from optparse import OptionParser
+--- 32,38 ----
+ import sys
+ import os
+ import StringIO
+! import hashlib
+ import vinreport
+
+ from optparse import OptionParser
+***************
+*** 149,155 ****
+ outputdir += "/"
+
+ try:
+! import Image
+ PIL = "imported"
+ except ImportError, e:
+ print >> sys.stderr, ""
+--- 149,155 ----
+ outputdir += "/"
+
+ try:
+! from PIL import Image
+ PIL = "imported"
+ except ImportError, e:
+ print >> sys.stderr, ""
+***************
+*** 164,170 ****
+ if htmlrep == True:
+ report = vinreport.HtRep(tDBfname, outputdir, getencodings(), __version__ + " (r" + \
+ __revision__[11:-2] +")")
+! md5tDB = md5.new(thumbsDB).hexdigest()
+ report.SetFileSection(longueur, md5tDB)
+
+ # -----------------------------------------------------------------------------
+--- 164,170 ----
+ if htmlrep == True:
+ report = vinreport.HtRep(tDBfname, outputdir, getencodings(), __version__ + " (r" + \
+ __revision__[11:-2] +")")
+! md5tDB = hashlib.md5(thumbsDB).hexdigest()
+ report.SetFileSection(longueur, md5tDB)
+
+ # -----------------------------------------------------------------------------