summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcopygirl2019-11-14 22:33:21 +0100
committercopygirl2019-11-14 22:33:21 +0100
commit897ffcb78bfe4053959069770cf5b0c550a0c6bb (patch)
tree5bcffe17823100d11a546de7028d6243dc4ac7ad
parent3042b5f48e3819942caceb4d9f18ff78d6e37bc8 (diff)
downloadaur-897ffcb78bfe4053959069770cf5b0c550a0c6bb.tar.gz
New release 1.11.0 "Game Challenge Update"
Also updated PKGBUILD to make specifying non-stable releases easier.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e191ca1ee02a..957ae223ff4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vintagestory
pkgdesc = An in-development indie sandbox game about innovation and exploration
- pkgver = 1.10.19
+ pkgver = 1.11.0
pkgrel = 1
url = https://www.vintagestory.at/
arch = any
@@ -8,10 +8,10 @@ pkgbase = vintagestory
depends = mono
depends = opengl-driver
depends = openal
- source = https://cdn.vintagestory.at/gamefiles/stable/vs_archive_1.10.19.tar.gz
+ source = https://cdn.vintagestory.at/gamefiles/stable/vs_archive_1.11.0.tar.gz
source = vintagestory.desktop
source = vintagestory.sh
- md5sums = b488965c0e12bec2b49872eb9784fb8d
+ md5sums = 616b3676f9df6d116a04b4e4f6d493a6
md5sums = ab6680c4499b58b14aa36acc2ab4038a
md5sums = da232b56f48e047ec60791bb7d8b6398
diff --git a/PKGBUILD b/PKGBUILD
index ef953406f336..68baa8dbd04a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,13 @@
# Maintainer: copygirl <copygirl@mcft.net>
pkgname=vintagestory
+
+# _release is the version's release type, commonly "stable" for normal releases,
+# "unstable" for release candidates and "pre" for testing releases before big updates.
+_release=stable
# _pkgver is separate to allow specifying pre-release versions such as "-rc.1".
-# makepkg doesn't support hyphens in pkgver. They'll be replaced by underscores.
-_pkgver=1.10.19
+_pkgver=1.11.0
+
+# makepkg doesn't support hyphens in pkgver. They'll be replaced with underscores.
pkgver=${_pkgver//-/_}
pkgrel=1
pkgdesc="An in-development indie sandbox game about innovation and exploration"
@@ -10,11 +15,11 @@ arch=("any")
url="https://www.vintagestory.at/"
license=("custom")
depends=("mono" "opengl-driver" "openal")
-source=("https://cdn.vintagestory.at/gamefiles/stable/vs_archive_$_pkgver.tar.gz"
-# "https://account.vintagestory.at/files/stable/vs_archive_$_pkgver.tar.gz" (alternative source)
+source=("https://cdn.vintagestory.at/gamefiles/$_release/vs_archive_$_pkgver.tar.gz"
+# "https://account.vintagestory.at/files/$_release/vs_archive_$_pkgver.tar.gz" (alternative source)
"vintagestory.desktop"
"vintagestory.sh")
-md5sums=("b488965c0e12bec2b49872eb9784fb8d"
+md5sums=("616b3676f9df6d116a04b4e4f6d493a6"
"ab6680c4499b58b14aa36acc2ab4038a"
"da232b56f48e047ec60791bb7d8b6398")
@@ -27,7 +32,7 @@ prepare() {
}
package() {
- # Copy console launcher .sh
+ # Copy terminal launcher script
install -Dm755 "$pkgname".sh "$pkgdir"/usr/bin/"$pkgname"
# Copy application icon and .desktop launcher file
install -Dm644 "$pkgname"/assets/gameicon.xpm "$pkgdir"/usr/share/pixmaps/"$pkgname".xpm