summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcopygirl2024-01-01 22:10:32 +0100
committercopygirl2024-01-01 22:10:32 +0100
commita954a34d89caff8234fea62b789f59154bc484a4 (patch)
treea008dea457d2c35f6ca1f47fe405293bb72d4657
parente1a0c663daea91024e6bc9ad71697c19b34371d9 (diff)
downloadaur-a954a34d89caff8234fea62b789f59154bc484a4.tar.gz
Update dependencies and add 1-click mod install support
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rw-r--r--vsmodinstall-handler.desktop10
3 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7cc15547760..b87f2c2cb64c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = vintagestory
pkgdesc = Uncompromising wilderness survival sandbox game (requires paid account)
pkgver = 1.18.15
- pkgrel = 1
+ pkgrel = 2
url = https://www.vintagestory.at/
arch = x86_64
license = custom
- depends = dotnet-runtime
+ depends = dotnet-runtime-7.0
depends = opengl-driver
depends = openal
+ depends = glibc>=2.34
source = https://cdn.vintagestory.at/gamefiles/stable/vs_client_linux-x64_1.18.15.tar.gz
source = vintagestory.desktop
+ source = vsmodinstall-handler.desktop
md5sums = f2fb522cd3622454e6fb05280a207555
md5sums = 26ff9ca4fb0a583589f26f2c274d4ec6
+ md5sums = e77871150115253e0d8c31b77a274182
pkgname = vintagestory
diff --git a/PKGBUILD b/PKGBUILD
index 450c38eb1364..113f134a70f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,17 +9,19 @@ _pkgver=1.18.15
# makepkg doesn't support hyphens in pkgver. They'll be replaced with underscores.
pkgver=${_pkgver//-/_}
-pkgrel=1
+pkgrel=2
pkgdesc="Uncompromising wilderness survival sandbox game (requires paid account)"
arch=("x86_64")
url="https://www.vintagestory.at/"
license=("custom")
-depends=("dotnet-runtime" "opengl-driver" "openal")
+depends=("dotnet-runtime-7.0" "opengl-driver" "openal" "glibc>=2.34")
source=("https://cdn.vintagestory.at/gamefiles/$_release/vs_client_linux-x64_$_pkgver.tar.gz"
# "https://account.vintagestory.at/files/$_release/vs_client_linux-x64_$_pkgver.tar.gz" (alternative source)
- "vintagestory.desktop")
+ "$pkgname.desktop"
+ "vsmodinstall-handler.desktop")
md5sums=("f2fb522cd3622454e6fb05280a207555"
- "26ff9ca4fb0a583589f26f2c274d4ec6")
+ "26ff9ca4fb0a583589f26f2c274d4ec6"
+ "e77871150115253e0d8c31b77a274182")
prepare() {
# Remove install script provided by developers
@@ -33,9 +35,10 @@ prepare() {
}
package() {
- # Copy application icon and .desktop launcher file
+ # Copy application icon and .desktop files
install -Dm644 "$pkgname"/assets/gameicon.xpm "$pkgdir"/usr/share/pixmaps/"$pkgname".xpm
install -Dm644 "$pkgname".desktop "$pkgdir"/usr/share/applications/"$pkgname".desktop
+ install -Dm644 vsmodinstall-handler.desktop "$pkgdir"/usr/share/applications/vsmodinstall-handler.desktop
# Copy fonts to /usr/share/fonts
install -Dm644 -t "$pkgdir"/usr/share/fonts/TTF/ "$pkgname"/assets/game/fonts/*.ttf
# Copy all other application files
diff --git a/vsmodinstall-handler.desktop b/vsmodinstall-handler.desktop
new file mode 100644
index 000000000000..7e931cb94dd7
--- /dev/null
+++ b/vsmodinstall-handler.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Vintage Story 1-click Mod Install Handler
+Comment=Handler for vintagestorymodinstall:// URI scheme
+Exec=/usr/bin/vintagestory -i %u
+Path=/usr/share/vintagestory
+MimeType=x-scheme-handler/vintagestorymodinstall;
+NoDisplay=true
+Terminal=false