summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul-Louis Ageneau2021-07-07 16:04:53 +0200
committerPaul-Louis Ageneau2021-07-07 16:04:53 +0200
commit7aaf1d398f0cf20f7d3f1301909f0749d2f07424 (patch)
treef9d26e56676f06419e9649f94d34c6d36490c272
downloadaur-7aaf1d398f0cf20f7d3f1301909f0749d2f07424.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb66e997c813
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = violet
+ pkgdesc = Lightweight STUN/TURN server
+ pkgver = v0.2.1
+ pkgrel = 1
+ url = https://github.com/paullouisageneau/violet
+ arch = x86_64
+ license = AGPL
+ makedepends = git
+ makedepends = cmake
+ provides = violet
+ conflicts = violet
+ source = git+https://github.com/paullouisageneau/violet.git#tag=v0.2.1
+ md5sums = SKIP
+
+pkgname = violet
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d1ef80e3adf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Paul-Louis Ageneau <paul-louis at ageneau dot org>
+
+pkgname=violet
+pkgver=v0.2.1
+pkgrel=1
+pkgdesc="Lightweight STUN/TURN server"
+arch=('x86_64')
+url="https://github.com/paullouisageneau/$pkgname"
+license=('AGPL')
+makedepends=('git' 'cmake')
+depends=()
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("git+https://github.com/paullouisageneau/$pkgname.git#tag=$pkgver")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$pkgname"
+ rm -rf build
+ cmake -B build -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+ cd build
+ make
+}
+
+package() {
+ cd "$pkgname"
+ install -m755 -d "$pkgdir"/usr/bin
+ install -m755 build/"$pkgname" "$pkgdir"/usr/bin
+ install -m755 -d "$pkgdir"/usr/lib/systemd/system
+ install -m644 "$pkgname".service "$pkgdir"/usr/lib/systemd/system
+ install -m755 -d "$pkgdir"/etc/violet
+ install -m644 example.conf "$pkgdir"/etc/violet/violet.conf
+ install -m755 -d "$pkgdir"/usr/lib/sysusers.d
+ echo "u violet - \"Violet STUM/TURN server user\"" > "$pkgdir"/usr/lib/sysusers.d/violet.conf
+}
+