summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilherme Bember Duarte2022-04-17 17:46:14 -0300
committerGuilherme Bember Duarte2022-04-17 17:46:14 -0300
commit2279c08c55f8fe1909d6eb4028f3d6e500e2753d (patch)
tree04ae6df6ea43c3139be9851f0264714c311fcd69
parent5181da19d390376faecf6eac954a18d9d0b8143e (diff)
downloadaur-2279c08c55f8fe1909d6eb4028f3d6e500e2753d.tar.gz
Updated to version 1.3.3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5730d81e46f7..ede3eeb588b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = viper-bin
pkgdesc = Viper is a launcher and updater for Northstar, and not much more than that.
- pkgver = 1.3.1
+ pkgver = 1.3.3
pkgrel = 1
- epoch = 2
url = https://github.com/0neGal/viper
arch = x86_64
license = GPL3
depends = nss
depends = alsa-lib
depends = gtk3
- source = https://github.com/0neGal/viper/releases/download/v1.3.1/viper_1.3.1_amd64.deb
- sha256sums = 032b688bbbb5a765c5a08425685e243c323f8c1702529ec0ba8e6cc40b6cc6db
+ source = https://github.com/0neGal/viper/releases/download/v1.3.3/viper_1.3.3_amd64.deb
+ sha256sums = fa0ff6646db88b4dda5143b0f305de85edfe75ebcb8faa11bb1726a8b404aa8c
pkgname = viper-bin
diff --git a/PKGBUILD b/PKGBUILD
index dfbed2716e68..3a788a141467 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Guilherme B. Duarte <guilhermebemberduarte@gmail.com>
pkgname=viper-bin
_pkgname=viper
-pkgver=1.3.1
+pkgver=1.3.3
pkgrel=1
-epoch=2
pkgdesc="Viper is a launcher and updater for Northstar, and not much more than that."
arch=('x86_64')
depends=('nss' 'alsa-lib' 'gtk3')
url="https://github.com/0neGal/${_pkgname}"
license=('GPL3')
source=("https://github.com/0neGal/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb")
-sha256sums=('032b688bbbb5a765c5a08425685e243c323f8c1702529ec0ba8e6cc40b6cc6db')
+sha256sums=('fa0ff6646db88b4dda5143b0f305de85edfe75ebcb8faa11bb1726a8b404aa8c')
package() {
tar -xf data.tar.xz -C "${pkgdir}"
mkdir ${pkgdir}/usr/bin
install -Dm644 "${pkgdir}/usr/share/icons/hicolor/0x0/apps/viper.png" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/viper.png"
rm -rf "${pkgdir}/usr/share/icons/hicolor/0x0"
- ln -s /opt/Viper/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ chmod 4755 "${pkgdir}/opt/Viper/chrome-sandbox"
+ ln -sf /opt/Viper/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
}