summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Rebischke2016-11-12 20:53:20 +0100
committerChristian Rebischke2016-11-12 20:53:20 +0100
commit61f5b3d751cbc9d1dff021cc6aeb46a7e32f75c7 (patch)
treec4a6558a7bf5354d4f29a99089373de4857f2295
parent80aa3506863567c87b46c6849b30d910729d52b9 (diff)
downloadaur-61f5b3d751cbc9d1dff021cc6aeb46a7e32f75c7.tar.gz
pkgbuild enhancements
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--viper-framework.install1
3 files changed, 9 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7f51038bae9..5de4a49a0ecf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Tue Mar 22 15:24:19 UTC 2016
pkgbase = viper-framework
pkgdesc = Stable version of Viper the Binary Analysis Framework
pkgver = 1.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/botherder/viper
install = viper-framework.install
arch = any
@@ -28,10 +26,8 @@ pkgbase = viper-framework
depends = python2-crypto
depends = python2-olefile
depends = python2-oletools
- source = https://github.com/botherder/viper/archive/v1.2.tar.gz
- source = viper-framework.install
+ source = viper-framework-1.2.tar.gz::https://github.com/botherder/viper/archive/v1.2.tar.gz
sha512sums = 07ed69479a472a9c909ea57661af33fc8f5a50df4e3af627658dea26d1e5e7f0fef5baef783a4042506e4eb702e757dea8da8e7fd3002d0ae77c053d9f74aee2
- sha512sums = 5f2446433205c4b04b7a2aad4c2262dfd54dc25a034a1b94f8de45a37a164c3fccdebdda60446148ddb940a5f84257426cbda21b7815d1e7b3cea5e9af54c0fe
pkgname = viper-framework
diff --git a/PKGBUILD b/PKGBUILD
index 2d69e6752252..5aa0cfbb9ae7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=viper-framework
pkgver=1.2
-pkgrel=2
+pkgrel=3
pkgdesc="Stable version of Viper the Binary Analysis Framework"
arch=("any")
url="https://github.com/botherder/viper"
@@ -13,21 +13,18 @@ depends=(
"python2-requests" "python2-sqlalchemy" "python2-prettytable" "python2-magic"
"python2-pydeep" "ssdeep" "python2-ssdeep" "python2-beautifulsoup4"
"python2-pefile" "python2-crypto" "python2-olefile" "python2-oletools")
-source=("https://github.com/botherder/viper/archive/v${pkgver}.tar.gz"
- "viper-framework.install")
-sha512sums=(
-"07ed69479a472a9c909ea57661af33fc8f5a50df4e3af627658dea26d1e5e7f0fef5baef783a4042506e4eb702e757dea8da8e7fd3002d0ae77c053d9f74aee2"
-"5f2446433205c4b04b7a2aad4c2262dfd54dc25a034a1b94f8de45a37a164c3fccdebdda60446148ddb940a5f84257426cbda21b7815d1e7b3cea5e9af54c0fe")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/botherder/viper/archive/v${pkgver}.tar.gz")
+sha512sums=("07ed69479a472a9c909ea57661af33fc8f5a50df4e3af627658dea26d1e5e7f0fef5baef783a4042506e4eb702e757dea8da8e7fd3002d0ae77c053d9f74aee2")
install="viper-framework.install"
build() {
- cd "viper-$pkgver"
+ cd "viper-${pkgver}"
python2 -m compileall .
python2 -O -m compileall .
}
package() {
- cd "$srcdir/viper-$pkgver"
- mkdir -p "$pkgdir/opt/viper/"
- mv * "$pkgdir/opt/viper/"
+ cd "${srcdir}/viper-${pkgver}"
+ mkdir -p "${pkgdir}/opt/viper/"
+ mv * "${pkgdir}/opt/viper/"
}
diff --git a/viper-framework.install b/viper-framework.install
index c78e1e6b9eaa..c04c0f9ab938 100644
--- a/viper-framework.install
+++ b/viper-framework.install
@@ -1,7 +1,6 @@
#!/bin/bash
post_install(){
- echo "[+] viper was installed to /opt/viper"
chmod ugo+w /opt/viper
}