summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-07-10 02:32:07 +0200
committeranthraxx2015-07-10 02:32:07 +0200
commitbd14656a6243ac85cce16814ba70e3b26b264f6c (patch)
tree39f593ed8c83348abc45517b2de347344e1ac17f
downloadaur-bd14656a6243ac85cce16814ba70e3b26b264f6c.tar.gz
addpkg: viper-framework 1.2-2
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD33
-rw-r--r--viper-framework.install8
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..383ee85cc1a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = viper-framework
+ pkgdesc = Stable version of Viper the Binary Analysis Framework
+ pkgver = 1.2
+ pkgrel = 2
+ url = https://github.com/botherder/viper
+ install = viper-framework.install
+ arch = any
+ license = BSD
+ depends = python2-pyexiftool
+ depends = python2-pylzma
+ depends = python2-bottle
+ depends = python2-pyelftools
+ depends = python2-bitstring
+ depends = python2-dnspython
+ depends = python2-m2crypto
+ depends = python2-pyasn1
+ depends = python2-requests
+ depends = python2-sqlalchemy
+ depends = python2-prettytable
+ depends = python2-magic
+ depends = python2-pydeep
+ depends = ssdeep
+ depends = python2-ssdeep
+ depends = python2-beautifulsoup4
+ depends = python2-pefile
+ depends = python2-crypto
+ depends = python2-olefile
+ depends = python2-oletools
+ source = https://github.com/botherder/viper/archive/v1.2.tar.gz
+ source = viper-framework.install
+ sha512sums = 07ed69479a472a9c909ea57661af33fc8f5a50df4e3af627658dea26d1e5e7f0fef5baef783a4042506e4eb702e757dea8da8e7fd3002d0ae77c053d9f74aee2
+ sha512sums = 5f2446433205c4b04b7a2aad4c2262dfd54dc25a034a1b94f8de45a37a164c3fccdebdda60446148ddb940a5f84257426cbda21b7815d1e7b3cea5e9af54c0fe
+
+pkgname = viper-framework
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8f6bb631c44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+#Maintainer: Christian Rebischke <echo Q2hyaXMuUmViaXNjaGtlQGdtYWlsLmNvbQo= | base64 -d>
+
+pkgname=viper-framework
+pkgver=1.2
+pkgrel=2
+pkgdesc="Stable version of Viper the Binary Analysis Framework"
+arch=("any")
+url=("https://github.com/botherder/viper")
+license=("BSD")
+depends=(
+"python2-pyexiftool" "python2-pylzma" "python2-bottle" "python2-pyelftools"
+"python2-bitstring" "python2-dnspython" "python2-m2crypto" "python2-pyasn1"
+"python2-requests" "python2-sqlalchemy" "python2-prettytable" "python2-magic"
+"python2-pydeep" "ssdeep" "python2-ssdeep" "python2-beautifulsoup4"
+"python2-pefile" "python2-crypto" "python2-olefile" "python2-oletools")
+source=("https://github.com/botherder/viper/archive/v${pkgver}.tar.gz"
+ "viper-framework.install")
+sha512sums=(
+"07ed69479a472a9c909ea57661af33fc8f5a50df4e3af627658dea26d1e5e7f0fef5baef783a4042506e4eb702e757dea8da8e7fd3002d0ae77c053d9f74aee2"
+"5f2446433205c4b04b7a2aad4c2262dfd54dc25a034a1b94f8de45a37a164c3fccdebdda60446148ddb940a5f84257426cbda21b7815d1e7b3cea5e9af54c0fe")
+install="viper-framework.install"
+
+build() {
+ cd "viper-$pkgver"
+ python2 -m compileall .
+ python2 -O -m compileall .
+}
+
+package() {
+ cd "$srcdir/viper-$pkgver"
+ mkdir -p "$pkgdir/opt/viper/"
+ mv * "$pkgdir/opt/viper/"
+}
diff --git a/viper-framework.install b/viper-framework.install
new file mode 100644
index 000000000000..c78e1e6b9eaa
--- /dev/null
+++ b/viper-framework.install
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+post_install(){
+ echo "[+] viper was installed to /opt/viper"
+ chmod ugo+w /opt/viper
+}
+
+