summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomoki Imai2016-01-26 02:54:57 +0900
committerTomoki Imai2016-01-26 02:54:57 +0900
commit4a67119551422a1fd7bba51c0765345a02344aa1 (patch)
tree14ad0e05a911de523531d72e720cd4ebe3662888
downloadaur-viqo-git.tar.gz
First import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18c36cbea5eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jan 25 17:54:38 UTC 2016
+pkgbase = viqo-git
+ pkgdesc = Viqo is a cross-platform "Nico Nama" comment viewer.
+ pkgver = v2.3.2.r1.g532dbda
+ pkgrel = 1
+ url = https://github.com/diginatu/Viqo
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = gcc
+ depends = qt5-base
+ source = viqo-git::git://github.com/diginatu/Viqo.git
+ md5sums = SKIP
+
+pkgname = viqo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7699300e07b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Tomoki Imai <tomo832@gmail.com>
+pkgname=viqo-git
+pkgver=v2.3.2.r1.g532dbda
+pkgdesc="Viqo is a cross-platform \"Nico Nama\" comment viewer."
+arch=('i686' 'x86_64')
+url="https://github.com/diginatu/Viqo"
+license=('MIT')
+groups=()
+depends=('qt5-base')
+makedepends=('git' 'gcc')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+
+source=("$pkgname"::'git://github.com/diginatu/Viqo.git')
+md5sums=('SKIP')
+pkgrel=1
+
+
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ qmake
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ # I don't know why, but it does nothing.
+ # make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm755 "$srcdir/$pkgname/viqo" "$pkgdir/usr/bin/viqo"
+ install -Dm644 "$srcdir/$pkgname/img/icon.svg" "$pkgdir/usr/share/pixmaps/icon.png"
+}