summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-12-23 14:22:31 +0100
committerPhilip Goto2018-12-23 14:22:31 +0100
commit0d6ff46295fb716998aac495716ddcbb9311d68e (patch)
tree98e060f0abd86b46cd200ff8e8532b0166903aa4
parent9731e6bb71321a0b3c4e32fe4d98ea0c317f55bc (diff)
downloadaur-0d6ff46295fb716998aac495716ddcbb9311d68e.tar.gz
Add check and change description and versioning
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df8fd09c2d4f..bd6aced37d14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = virtboard-git
- pkgdesc = A basic keyboard, blazing the path of modern Wayland keyboards. Sacrificial.
- pkgver = r6272.5210414c
+ pkgdesc = Basic keyboard, blazing the path of modern Wayland keyboards
+ pkgver = 0.0.5.r12.g49b04fb6
pkgrel = 1
url = https://source.puri.sm/Librem5/virtboard
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index f7b2b0803e75..8ace16005bf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=virtboard-git
-pkgver=r6272.5210414c
+pkgver=0.0.5.r12.g49b04fb6
pkgrel=1
-pkgdesc="A basic keyboard, blazing the path of modern Wayland keyboards. Sacrificial."
+pkgdesc="Basic keyboard, blazing the path of modern Wayland keyboards"
url="https://source.puri.sm/Librem5/virtboard"
license=("GPL3")
arch=(i686 x86_64 armv6h armv7h)
@@ -18,15 +18,18 @@ sha256sums=("SKIP")
pkgver() {
cd virtboard
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- rm -rf build
- arch-meson virtboard build -Dtests=false
+ arch-meson virtboard build
ninja -C build
}
+check() {
+ ninja -C build test
+}
+
package() {
DESTDIR="${pkgdir}" ninja -C build install
}