summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2024-02-26 15:22:05 +0100
committerMarcell Meszaros2024-02-26 15:25:27 +0100
commit38376acc16de94d5994dd45ef328b77f04555b51 (patch)
tree7ce9d72a3dc4d72b998f6e92edf9ccda86c838d2
parent2255fafddf62547bb2072f6dee9a9b2e19d10e17 (diff)
downloadaur-virtscreen.tar.gz
v0.3.2 (dderjoel's continuation fork)
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore18
-rw-r--r--001-remove-pyqt5.patch14
-rw-r--r--PKGBUILD54
4 files changed, 74 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce8752a3919b..71aa05c799e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,30 @@
pkgbase = virtscreen
- pkgdesc = Make your iPad/tablet/computer as a secondary monitor on Linux
- pkgver = 0.3.1
- pkgrel = 2
- url = https://github.com/kbumsik/VirtScreen
+ pkgdesc = Use your iPad/tablet/computer as a secondary monitor on Linux (dderjoel's continuation fork)
+ pkgver = 0.3.2
+ pkgrel = 1
+ url = https://github.com/dderjoel/VirtScreen
arch = any
- license = GPL3
+ license = GPL-3.0-only
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- depends = xorg-xrandr
- depends = x11vnc
- depends = python-pyqt5
- depends = qt5-quickcontrols2
- depends = python-quamash
+ makedepends = python-wheel
+ depends = python
depends = python-netifaces
+ depends = python-pyqt5
+ depends = python-qasync
+ depends = qt5-declarative
+ depends = qt5-quickcontrols
optdepends = arandr: for display settings option
- source = virtscreen-0.3.1.tar.gz::https://github.com/kbumsik/VirtScreen/archive/refs/tags/0.3.1.tar.gz
- source = 001-remove-pyqt5.patch
- sha256sums = 345c9333a0129db660d07687fbfa479fd69bf9fe387510b987207463c7a55257
- sha256sums = 95772f671ff329e3e7ef791999dc9f131647bc0f92c3a23e43813399659c62c9
+ source = VirtScreen-0.3.2.tar.gz::https://github.com/dderjoel/VirtScreen/archive/refs/tags/0.3.2.tar.gz
+ b2sums = 2c9480f0cb96401628dd67f8e3d143d6cb386421106e6e42d7dc4793ad61d12df33c8f31bdc33e222952241f07fd100d6738d8aa754b751ae98bcb4439f08340
pkgname = virtscreen
+ depends = python
+ depends = python-netifaces
+ depends = python-pyqt5
+ depends = python-qasync
+ depends = qt5-declarative
+ depends = qt5-quickcontrols
+ depends = x11vnc
+ depends = xorg-xrandr
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..058ba2318df1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+# based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+
+*/
+*.orig
+*.bak
+*.backup
+*.kate-swp
+.directory
diff --git a/001-remove-pyqt5.patch b/001-remove-pyqt5.patch
deleted file mode 100644
index 08679cfba141..000000000000
--- a/001-remove-pyqt5.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 36eeb37..27a12c1 100644
---- a/setup.py
-+++ b/setup.py
-@@ -143,8 +143,7 @@ setup(
- #
- # For an analysis of "install_requires" vs pip's requirements files see:
- # https://packaging.python.org/en/latest/requirements.html
-- install_requires=['PyQt5>=5.10.1',
-- 'Quamash>=0.6.0',
-+ install_requires=['Quamash>=0.6.0',
- 'netifaces>=0.10.6'], # Optional
-
- # List additional groups of dependencies here (e.g. development
diff --git a/PKGBUILD b/PKGBUILD
index 2643fde1a056..de6842e2f8a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,44 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Luis Martinez <luis dot martinez at tuta dot io>
# Contributor: Bumsik Kim <k.bumsik@gmail.com>
+_distname=VirtScreen
pkgname=virtscreen
-pkgver=0.3.1
-pkgrel=2
-pkgdesc="Make your iPad/tablet/computer as a secondary monitor on Linux"
+pkgver=0.3.2
+pkgrel=1
+pkgdesc="Use your iPad/tablet/computer as a secondary monitor on Linux (dderjoel's continuation fork)"
arch=('any')
-url="https://github.com/kbumsik/VirtScreen"
-license=('GPL3')
-depends=('xorg-xrandr' 'x11vnc' 'python-pyqt5' 'qt5-quickcontrols2' 'python-quamash' 'python-netifaces')
-makedepends=('python-setuptools')
+url="https://github.com/dderjoel/${_distname}"
+license=('GPL-3.0-only')
+depends=(
+ 'python'
+ 'python-netifaces'
+ 'python-pyqt5'
+ 'python-qasync'
+ 'qt5-declarative'
+ 'qt5-quickcontrols'
+)
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
optdepends=('arandr: for display settings option')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz"
- '001-remove-pyqt5.patch')
-sha256sums=('345c9333a0129db660d07687fbfa479fd69bf9fe387510b987207463c7a55257'
- '95772f671ff329e3e7ef791999dc9f131647bc0f92c3a23e43813399659c62c9')
-
-prepare() {
- cd "VirtScreen-$pkgver"
- patch -p1 < "$srcdir/001-remove-pyqt5.patch"
-}
+_tarname="${_distname}-${pkgver}"
+source=("${_tarname}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
+b2sums=('2c9480f0cb96401628dd67f8e3d143d6cb386421106e6e42d7dc4793ad61d12df33c8f31bdc33e222952241f07fd100d6738d8aa754b751ae98bcb4439f08340')
build() {
- cd "VirtScreen-$pkgver"
- python setup.py build
+ cd "${_tarname}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "VirtScreen-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ depends+=(
+ 'x11vnc'
+ 'xorg-xrandr'
+ )
+ cd "${_tarname}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}