summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-07-22 19:33:26 +0000
committerDaniel Bermond2018-07-22 19:33:26 +0000
commit1751a9f8f626eec3e7e2a5526bb282883ce65c83 (patch)
tree8ab20d2ade419a2cbf1a9778a012a4631b5da402
parentd451432d7926f44250b00984fdd57597f365b475 (diff)
downloadaur-1751a9f8f626eec3e7e2a5526bb282883ce65c83.tar.gz
Add i686 support
This will enable the package to be used by the (usually forgotten) ArchLinux32 users.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9a8afcfff64..ec1c6cbbcc4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = virtualbox-bin
pkgdesc = Oracle VM VirtualBox Binary Edition (Oracle branded non-OSE version)
pkgver = 5.2.14
- pkgrel = 3
+ pkgrel = 4
url = https://www.virtualbox.org/
install = virtualbox-bin.install
+ arch = i686
arch = x86_64
license = GPL2
makedepends = linux-headers
@@ -27,7 +28,6 @@ pkgbase = virtualbox-bin
options = !strip
backup = etc/vbox/vbox.cfg
backup = etc/conf.d/vboxweb
- source = http://download.virtualbox.org/virtualbox/5.2.14/VirtualBox-5.2.14-123301-Linux_amd64.run
source = VBoxFixUSB
source = 10-vboxdrv.rules
source = vboxweb.rc
@@ -35,7 +35,6 @@ pkgbase = virtualbox-bin
source = do_dkms
source = dkms.conf
source = 009-include-path.patch
- sha256sums = 2ea513dadaab9b32df6c18827ebfe98524e297d2b44678ce1518a3486d8b3e73
sha256sums = 0aebe22abab402ea6b6573af637a99d8056a904920a52d84fb97729219219c23
sha256sums = 69417a9e8855cab8e4878886abe138f559fd17ae487d4cd19c8a24974a8bbec2
sha256sums = 656905de981ffa24f6f921c920538854a235225053f44baedacc07b46ca0cf56
@@ -43,6 +42,10 @@ pkgbase = virtualbox-bin
sha256sums = cc1c0500ab07bc13563d99037f776bf64bdc90bb521e31e2e0b04e42ea5bb36a
sha256sums = e9df0fff15184d0a90abe17707bdbe1931582433bbc14ded4fb3b0252653c801
sha256sums = 5112f0e1ba3bd0bd92ef2edb2d21024e265abb02841aa29aa05410526adc273f
+ source_i686 = http://download.virtualbox.org/virtualbox/5.2.14/VirtualBox-5.2.14-123301-Linux_x86.run
+ sha256sums_i686 = 19dac9ef4b19b74b67196f0c87bc17ca9459ca6c1bb5731ac9de4374586e260a
+ source_x86_64 = http://download.virtualbox.org/virtualbox/5.2.14/VirtualBox-5.2.14-123301-Linux_amd64.run
+ sha256sums_x86_64 = 2ea513dadaab9b32df6c18827ebfe98524e297d2b44678ce1518a3486d8b3e73
pkgname = virtualbox-bin
diff --git a/PKGBUILD b/PKGBUILD
index 75598196b55e..3cf9a237ce6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,9 @@
pkgname=virtualbox-bin
pkgver=5.2.14
_build=123301
-pkgrel=3
+pkgrel=4
pkgdesc='Oracle VM VirtualBox Binary Edition (Oracle branded non-OSE version)'
-arch=('x86_64')
+arch=('i686' 'x86_64')
url='https://www.virtualbox.org/'
license=('GPL2')
depends=('dkms' 'fontconfig' 'gcc' 'libgl' 'libidl2' 'libxcursor' 'libxinerama'
@@ -22,28 +22,33 @@ replaces=('virtualbox_bin' 'virtualbox-sun')
backup=('etc/vbox/vbox.cfg' 'etc/conf.d/vboxweb')
install="${pkgname}.install"
options=('!strip')
-source=("http://download.virtualbox.org/virtualbox/${pkgver}/VirtualBox-${pkgver}-${_build}-Linux_amd64.run"
- 'VBoxFixUSB'
+source=('VBoxFixUSB'
'10-vboxdrv.rules'
'vboxweb.rc'
'vboxweb.conf'
'do_dkms'
'dkms.conf'
'009-include-path.patch')
-sha256sums=('2ea513dadaab9b32df6c18827ebfe98524e297d2b44678ce1518a3486d8b3e73'
- '0aebe22abab402ea6b6573af637a99d8056a904920a52d84fb97729219219c23'
+source_i686=("http://download.virtualbox.org/virtualbox/${pkgver}/VirtualBox-${pkgver}-${_build}-Linux_x86.run")
+source_x86_64=("http://download.virtualbox.org/virtualbox/${pkgver}/VirtualBox-${pkgver}-${_build}-Linux_amd64.run")
+sha256sums=('0aebe22abab402ea6b6573af637a99d8056a904920a52d84fb97729219219c23'
'69417a9e8855cab8e4878886abe138f559fd17ae487d4cd19c8a24974a8bbec2'
'656905de981ffa24f6f921c920538854a235225053f44baedacc07b46ca0cf56'
'12dbba3b59991f2b68cddeeeda20236aeff63e11b7e2d1b08d9d6a82225f6651'
'cc1c0500ab07bc13563d99037f776bf64bdc90bb521e31e2e0b04e42ea5bb36a'
'e9df0fff15184d0a90abe17707bdbe1931582433bbc14ded4fb3b0252653c801'
'5112f0e1ba3bd0bd92ef2edb2d21024e265abb02841aa29aa05410526adc273f')
+sha256sums_i686=('19dac9ef4b19b74b67196f0c87bc17ca9459ca6c1bb5731ac9de4374586e260a')
+sha256sums_x86_64=('2ea513dadaab9b32df6c18827ebfe98524e297d2b44678ce1518a3486d8b3e73')
prepare() {
+ [ "$CARCH" = 'i686' ] && local _arch='x86'
+ [ "$CARCH" = 'x86_64' ] && local _arch='amd64'
+
mkdir -p "${pkgname}-${pkgver}"
# extract the source file
- yes | sh "VirtualBox-${pkgver}-${_build}-Linux_amd64.run" \
+ yes | sh "VirtualBox-${pkgver}-${_build}-Linux_${_arch}.run" \
--target "${srcdir}/${pkgname}-${pkgver}" \
--nox11 \
--noexec \