summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-08-16 14:53:38 +0000
committerDaniel Bermond2018-08-16 14:53:38 +0000
commit6d718b9bd2af40cb9d7be77c4bb76db9b9f287fc (patch)
treec8fcc25de89c70455b3ec2abd5f18545a279f86f
parent5b2bf9eebd9f0739d388fb7f7861a812009fa665 (diff)
downloadaur-6d718b9bd2af40cb9d7be77c4bb76db9b9f287fc.tar.gz
Updated to version 5.2.18
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b7ba9061a3a..e9bdf3a6c2ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = virtualbox-bin
pkgdesc = Oracle VM VirtualBox Binary Edition (Oracle branded non-OSE version)
- pkgver = 5.2.16
+ pkgver = 5.2.18
pkgrel = 1
url = https://www.virtualbox.org/
install = virtualbox-bin.install
@@ -19,7 +19,7 @@ pkgbase = virtualbox-bin
depends = python
depends = sdl
optdepends = virtualbox-ext-oracle: for Oracle extensions
- provides = virtualbox=5.2.16
+ provides = virtualbox=5.2.18
conflicts = virtualbox
conflicts = virtualbox-host-dkms
conflicts = virtualbox-host-modules-arch
@@ -42,10 +42,10 @@ pkgbase = virtualbox-bin
sha256sums = cc1c0500ab07bc13563d99037f776bf64bdc90bb521e31e2e0b04e42ea5bb36a
sha256sums = e9df0fff15184d0a90abe17707bdbe1931582433bbc14ded4fb3b0252653c801
sha256sums = 5112f0e1ba3bd0bd92ef2edb2d21024e265abb02841aa29aa05410526adc273f
- source_i686 = http://download.virtualbox.org/virtualbox/5.2.16/VirtualBox-5.2.16-123759-Linux_x86.run
- sha256sums_i686 = c745d917e3282fec262d94401fab8af403eeeb9659032958d488668ce68e71a2
- source_x86_64 = http://download.virtualbox.org/virtualbox/5.2.16/VirtualBox-5.2.16-123759-Linux_amd64.run
- sha256sums_x86_64 = 1a0708d7242c4d0590c9a7ba1d7b497065f8429d27cb4622c0260cc7cf667da4
+ source_i686 = http://download.virtualbox.org/virtualbox/5.2.18/VirtualBox-5.2.18-124319-Linux_x86.run
+ sha256sums_i686 = 56c6e5c4396d6651ed3fda328ccfcfe82090fe0df595a500d992bdc8a7053338
+ source_x86_64 = http://download.virtualbox.org/virtualbox/5.2.18/VirtualBox-5.2.18-124319-Linux_amd64.run
+ sha256sums_x86_64 = 3cb4b8550287cedd5042c0df2d4dfc4f0816cea6485f68f259bd2b06608769cd
pkgname = virtualbox-bin
diff --git a/PKGBUILD b/PKGBUILD
index 42683824b7aa..d5e293c07f3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: M0Rf30
pkgname=virtualbox-bin
-pkgver=5.2.16
-_build=123759
+pkgver=5.2.18
+_build=124319
pkgrel=1
pkgdesc='Oracle VM VirtualBox Binary Edition (Oracle branded non-OSE version)'
arch=('i686' 'x86_64')
@@ -38,8 +38,8 @@ sha256sums=('0aebe22abab402ea6b6573af637a99d8056a904920a52d84fb97729219219c23'
'cc1c0500ab07bc13563d99037f776bf64bdc90bb521e31e2e0b04e42ea5bb36a'
'e9df0fff15184d0a90abe17707bdbe1931582433bbc14ded4fb3b0252653c801'
'5112f0e1ba3bd0bd92ef2edb2d21024e265abb02841aa29aa05410526adc273f')
-sha256sums_i686=('c745d917e3282fec262d94401fab8af403eeeb9659032958d488668ce68e71a2')
-sha256sums_x86_64=('1a0708d7242c4d0590c9a7ba1d7b497065f8429d27cb4622c0260cc7cf667da4')
+sha256sums_i686=('56c6e5c4396d6651ed3fda328ccfcfe82090fe0df595a500d992bdc8a7053338')
+sha256sums_x86_64=('3cb4b8550287cedd5042c0df2d4dfc4f0816cea6485f68f259bd2b06608769cd')
prepare() {
[ "$CARCH" = 'i686' ] && local _arch='x86'
@@ -63,7 +63,7 @@ package() {
install -d "${pkgdir}/${_installdir}"
tar -jxf "${srcdir}/${pkgname}-${pkgver}/VirtualBox.tar.bz2" -C "${pkgdir}/${_installdir}"
- # patch 009-includepath (thanks to Christian Hesse)
+ # apply patch 009-include-path (thanks to Christian Hesse)
msg2 "Applying patch '009-includepath.patch'..."
cd "${pkgdir}/${_installdir}/src/vboxhost/"
patch -Np5 -i "${srcdir}/009-include-path.patch"
@@ -80,21 +80,21 @@ package() {
chmod go-w "${pkgdir}/${_installdir}"
# install SDK
- msg2 "Installing SDK..."
+ msg2 'Installing SDK...'
pushd 'sdk/installer' >/dev/null
VBOX_INSTALL_PATH="$_installdir" python vboxapisetup.py install --root "$pkgdir"
rm -rf build
popd >/dev/null
# install udev rules
- msg2 "Installing udev rules..."
+ msg2 'Installing udev rules...'
install -D -m0644 "${srcdir}/10-vboxdrv.rules" "${pkgdir}/usr/lib/udev/rules.d/10-vboxdrv.rules"
## we need to copy and not symlink VBoxCreateUSBNode.sh in /usr/lib/udev to avoid udevd
## to look /opt when /opt is not mounted. This can be done until VBoxCreateUSBNode.sh doesn't
## need more stuff from /opt
cp -a VBoxCreateUSBNode.sh "${pkgdir}/usr/lib/udev/"
- msg2 "Installing scripts..."
+ msg2 'Installing scripts...'
# install VBoxFixUSB script
install -D -m0755 "${srcdir}/VBoxFixUSB" VBoxFixUSB
@@ -103,7 +103,7 @@ package() {
install -D -m0755 "${srcdir}/vboxweb.rc" "${pkgdir}/etc/rc.d/vboxweb"
install -D -m0644 "${srcdir}/vboxweb.conf" "${pkgdir}/etc/conf.d/vboxweb"
- msg2 "Creating needed symlinks..."
+ msg2 'Creating needed symlinks...'
# symlink the launchers (second link can fail if fs is not case sensitive)
install -d -m0755 "${pkgdir}/usr/bin"
@@ -148,7 +148,7 @@ package() {
# with the relase of VirtualBox 5.1.0, Oracle dropped DKMS support from their package
# we will restore DKMS with the use of these config files
- msg2 "Installing DKMS support..."
+ msg2 'Installing DKMS support...'
install -D -m0755 "${srcdir}/do_dkms" -t "${pkgdir}/${_installdir}/src/vboxhost"
## update module version
cd "$srcdir"
@@ -157,12 +157,12 @@ package() {
install -D -m0644 "${pkgname}-${pkgver}/dkms.conf" -t "${pkgdir}/${_installdir}/src/vboxhost"
# module sources in /usr/src
- msg2 "Installing module sources..."
+ msg2 'Installing module sources...'
install -d -m0755 "${pkgdir}/usr/src"
mv "${pkgdir}/${_installdir}/src/vboxhost" "${pkgdir}/usr/src/vboxhost-${pkgver}"
# write the configuration file
- msg2 "Writing the configuration file..."
+ msg2 'Writing the configuration file...'
install -D -m0644 /dev/null "${pkgdir}/etc/vbox/vbox.cfg"
cat > "${pkgdir}/etc/vbox/vbox.cfg" <<EOF
# VirtualBox installation directory