summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTharbad2018-08-30 14:39:46 +0300
committerTharbad2018-08-30 14:39:46 +0300
commit0d91a054b35aa351405bf948c12ee10855d01fa5 (patch)
tree9ad8bd4de442c1dce5391779dbd3b1c0cdcb4119
parent72b11864754d7b736177d779241ae07be975f7a3 (diff)
downloadaur-0d91a054b35aa351405bf948c12ee10855d01fa5.tar.gz
Experimental auto updating version
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 104319406125..13965cb2fe33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,6 @@ pkgbase = virtualbox-ck-modules
pkgname = virtualbox-ck-host-modules
pkgdesc = Host kernel modules for VirtualBox running under Linux-ck.
- depends = linux-ck>=4.17
- depends = linux-ck<4.18
+ depends = linux-ck
provides = VIRTUALBOX-HOST-MODULES
diff --git a/PKGBUILD b/PKGBUILD
index a46747dd6166..745f761d3a85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,22 @@ url='http://virtualbox.org'
license=('GPL')
makedepends=('linux-ck-headers' "virtualbox-host-dkms>=$pkgver" "virtualbox-guest-dkms>=$pkgver" 'dkms')
-_extramodules=extramodules-ck
+# 1: Get the installed ck from pacman. ex: linux-ck-ivybridge 4.17.11-6
+# 2: Get first column. ex: linux-ck-ivybridge
+# 3: Get core version. ex: ivybridge
+_kernel="$(pacman -Q linux-ck | awk '{print $1}' | cut -d \- -f 3)"
+_extramodules=extramodules-ck-${_kernel}
_kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+
+pkgver() {
+ pacman -Ss virtualbox-host-dkms | awk 'NR==1{print $2}' | cut -d \- -f 1
+}
+
+pkgrel() {
+ pacman -Ss virtualbox-host-dkms | awk 'NR==1{print $2}' | cut -d \- -f 2
+}
+
build() {
# dkms need modification to be run as user
cp -r /var/lib/dkms .
@@ -28,7 +41,9 @@ package_virtualbox-ck-host-modules() {
#pkgdesc="${_Hpkgdesc}"
pkgdesc='Host kernel modules for VirtualBox running under Linux-ck.'
provides=("VIRTUALBOX-HOST-MODULES")
- depends=('linux-ck>=4.17' 'linux-ck<4.18')
+ depends=('linux-ck')
+ # In case needed. Repo version: pacman -Ss linux-ck-${_kernel} | awk 'NR==1{print $2}' | cut -d \- -f 1 | cut -d \. -f 1,2
+ #depends=('linux-ck>=4.17' 'linux-ck<4.18')
#replaces=('virtualbox-ck-host-modules-corex')
#groups=('ck-generic')