summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2020-03-19 20:08:28 +0100
committerKenjiTakahashi2020-03-19 20:08:28 +0100
commit2ca87a08e577ab6f8b1d02f61f433b26edd8eee7 (patch)
treeb5151b6c9e1360c1546462e1644ac62e5661e6fc
parent60f16f5f17a1411dc13d3298b88bbf9fd5a44753 (diff)
downloadaur-2ca87a08e577ab6f8b1d02f61f433b26edd8eee7.tar.gz
6.1.4-1: Bumped version
-rw-r--r--.SRCINFO10
-rw-r--r--014-vboxclient.patch70
-rw-r--r--PKGBUILD15
3 files changed, 85 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 547a5b3fedfd..99f77c925c89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = virtualbox-headless
pkgdesc = Powerful x86 virtualization for enterprise as well as home use. Headless build (no GUI, no Java).
- pkgver = 6.1.2
+ pkgver = 6.1.4
pkgrel = 1
url = https://virtualbox.org
install = virtualbox.install
@@ -28,13 +28,13 @@ pkgbase = virtualbox-headless
optdepends = virtualbox-guest-iso: Guest Additions CD image
optdepends = virtualbox-ext-vnc: VNC server support
optdepends = virtualbox-sdk: Developer kit
- provides = virtualbox=6.1.2
+ provides = virtualbox=6.1.4
conflicts = virtualbox-ose
conflicts = virtualbox
replaces = virtualbox-ose
replaces = virtualbox
backup = etc/vbox/vbox.cfg
- source = https://download.virtualbox.org/virtualbox/6.1.2/VirtualBox-6.1.2.tar.bz2
+ source = https://download.virtualbox.org/virtualbox/6.1.4/VirtualBox-6.1.4.tar.bz2
source = virtualbox.sysusers
source = 60-vboxdrv.rules
source = 60-vboxguest.rules
@@ -48,7 +48,8 @@ pkgbase = virtualbox-headless
source = 008-no-vboxvideo.patch
source = 012-vbglR3GuestCtrlDetectPeekGetCancelSupport.patch
source = 013-Makefile.patch
- sha256sums = 4326576e8428ea3626194fc82646347576e94c61f11d412a669fc8a10c2a1e67
+ source = 014-vboxclient.patch
+ sha256sums = 59f8f5774473f593e3eb5940e2a337e0674bcd9854164b2578fd43f896260c99
sha256sums = 2101ebb58233bbfadf3aa74381f22f7e7e508559d2b46387114bc2d8e308554c
sha256sums = 9c5238183019f9ebc7d92a8582cad232f471eab9d3278786225abc1a1c7bf66e
sha256sums = 033c597e0f5285d2ddb0490868e5b6f945f45c7b1b1152a02a9e6fea438b2c95
@@ -62,6 +63,7 @@ pkgbase = virtualbox-headless
sha256sums = 053bfeee8863f3ffdf2f0e3f9f0d77dc61dd32764700a97a7635fd8611e20491
sha256sums = 81900e13d36630488accd8c0bfd2ceb69563fb2c4f0f171caba1cca59d438024
sha256sums = da7e58ed37dc23c6202aab3017864579a99e78417f3421ddcc98a198198fe2c9
+ sha256sums = db617a3e7a3a94b96d5c3fe771d31c927242ef4f2cb265a22e4d5d64560a910a
pkgname = virtualbox-headless
diff --git a/014-vboxclient.patch b/014-vboxclient.patch
new file mode 100644
index 000000000000..77a614c2cd42
--- /dev/null
+++ b/014-vboxclient.patch
@@ -0,0 +1,70 @@
+--- a/src/VBox/Additions/x11/VBoxClient/clipboard.cpp
++++ b/src/VBox/Additions/x11/VBoxClient/clipboard.cpp
+@@ -107,7 +107,7 @@
+ else
+ #endif
+ {
+- uint32_t cbData = _4K; /** @ŧodo Make this dynamic. */
++ uint32_t cbData = _4K; /** @todo Make this dynamic. */
+ void *pvData = RTMemAlloc(cbData);
+ if (pvData)
+ {
+@@ -215,7 +215,6 @@
+ *
+ * @returns VBox status code.
+ */
+-#if 0
+ static int vboxClipboardConnect(void)
+ {
+ LogFlowFuncEnter();
+@@ -245,7 +244,6 @@
+ LogFlowFuncLeaveRC(rc);
+ return rc;
+ }
+-#endif
+
+ /**
+ * The main loop of our clipboard reader.
+@@ -469,7 +467,7 @@
+ RT_NOREF(ppInterface, fDaemonised);
+
+ /* Initialise the guest library. */
+- int rc = 0; //vboxClipboardConnect();
++ int rc = vboxClipboardConnect();
+ if (RT_SUCCESS(rc))
+ {
+ #ifdef VBOX_WITH_SHARED_CLIPBOARD_FUSE
+@@ -477,10 +475,8 @@
+ if (RT_SUCCESS(rc))
+ {
+ #endif
+- RTThreadSleep(60 * 1000);
++ rc = vboxClipboardMain();
+
+- //rc = vboxClipboardMain();
+-
+ #ifdef VBOX_WITH_SHARED_CLIPBOARD_FUSE
+ int rc2 = vboxClipboardFUSEStop();
+ if (RT_SUCCESS(rc))
+--- a/src/VBox/Additions/x11/VBoxClient/display-svga-x11.cpp
++++ b/src/VBox/Additions/x11/VBoxClient/display-svga-x11.cpp
+@@ -100,16 +100,19 @@ static void x11Connect(struct X11CONTEXT
+ {
+ XCloseDisplay(pContext->pDisplay);
+ pContext->pDisplay = NULL;
++ return;
+ }
+ if (!XRRQueryExtension(pContext->pDisplay, &pContext->hRandREventBase, &pContext->hRandRErrorBase))
+ {
+ XCloseDisplay(pContext->pDisplay);
+ pContext->pDisplay = NULL;
++ return;
+ }
+ if (!XRRQueryVersion(pContext->pDisplay, &pContext->hRandRMajor, &pContext->hRandRMinor))
+ {
+ XCloseDisplay(pContext->pDisplay);
+ pContext->pDisplay = NULL;
++ return;
+ }
+ pContext->rootWindow = DefaultRootWindow(pContext->pDisplay);
+ }
diff --git a/PKGBUILD b/PKGBUILD
index 4a4ee76d0b74..e825531aac8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Ionut Biru <ibiru@archlinux.org>
pkgname=virtualbox-headless
-pkgver=6.1.2
+pkgver=6.1.4
_tarver=${pkgver}
pkgrel=1
pkgdesc='Powerful x86 virtualization for enterprise as well as home use. Headless build (no GUI, no Java).'
@@ -37,9 +37,10 @@ source=("https://download.virtualbox.org/virtualbox/${pkgver}/VirtualBox-${_tarv
'008-no-vboxvideo.patch'
'012-vbglR3GuestCtrlDetectPeekGetCancelSupport.patch'
'013-Makefile.patch'
+ '014-vboxclient.patch'
)
sha256sums=(
- '4326576e8428ea3626194fc82646347576e94c61f11d412a669fc8a10c2a1e67'
+ '59f8f5774473f593e3eb5940e2a337e0674bcd9854164b2578fd43f896260c99'
'2101ebb58233bbfadf3aa74381f22f7e7e508559d2b46387114bc2d8e308554c'
'9c5238183019f9ebc7d92a8582cad232f471eab9d3278786225abc1a1c7bf66e'
'033c597e0f5285d2ddb0490868e5b6f945f45c7b1b1152a02a9e6fea438b2c95'
@@ -53,6 +54,7 @@ sha256sums=(
'053bfeee8863f3ffdf2f0e3f9f0d77dc61dd32764700a97a7635fd8611e20491'
'81900e13d36630488accd8c0bfd2ceb69563fb2c4f0f171caba1cca59d438024'
'da7e58ed37dc23c6202aab3017864579a99e78417f3421ddcc98a198198fe2c9'
+ 'db617a3e7a3a94b96d5c3fe771d31c927242ef4f2cb265a22e4d5d64560a910a'
)
prepare() {
@@ -81,12 +83,13 @@ build() {
./configure \
--build-headless \
--disable-docs \
- --enable-webservice \
- --enable-vde \
- --enable-vnc \
- --disable-java \
--disable-kmods \
+ --disable-vmmraw \
+ --disable-java \
--disable-alsa \
+ --enable-vde \
+ --enable-vnc \
+ --enable-webservice \
--with-makeself=/usr/bin/echo
# fake makeself binary to compile without nofatal
# makeself is used by linux installer. we don't need it.